Bug 458255 - Cannot install Yakuake from the link on the KDE page for it.
Summary: Cannot install Yakuake from the link on the KDE page for it.
Status: RESOLVED FIXED
Alias: None
Product: yakuake
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Eike Hein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-08-24 14:53 UTC by Keith Brown
Modified: 2022-08-26 09:08 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.7


Attachments
Screenshot from Discovery in Kubuntu 22.04 (48.89 KB, image/png)
2022-08-24 16:50 UTC, Keith Brown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Brown 2022-08-24 14:53:25 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***


STEPS TO REPRODUCE
1. Click the "Install to Linux" link on the yakuake page

OBSERVED RESULT
Receive an error that yakuake cannot be installed due to being not found.

EXPECTED RESULT
Yakuake installs via KDE Discovery

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.92.0
Qt Version: 15.5.3

ADDITIONAL INFORMATION
Have tried on multiple systems, same results. I think it is mostly due to there not being a version of yakuake on flathub and similar repos that the KDE org makes use of officially.
Comment 1 Nicolas Fella 2022-08-24 15:40:28 UTC
It is correct that Yakuake is not available from Flathub, packaging terminal apps as Flatpak is somewhat complex

However, Discover should offer you to install it from your distribution, assuming it is packaged there. What distribution is that and does it have a package for Yakuake?
Comment 2 Keith Brown 2022-08-24 16:50:09 UTC
Created attachment 151557 [details]
Screenshot from Discovery in Kubuntu 22.04
Comment 3 Keith Brown 2022-08-24 17:14:59 UTC
(In reply to Nicolas Fella from comment #1)
> It is correct that Yakuake is not available from Flathub, packaging terminal
> apps as Flatpak is somewhat complex
> 
> However, Discover should offer you to install it from your distribution,
> assuming it is packaged there. What distribution is that and does it have a
> package for Yakuake?

Tried first on my Steam Deck using Arch-Based SteamOS 3.0. After that failed, I tried on my laptop running Kubuntu 22.04. I know the Ubuntu repos include yakuake, as I've had it on my laptop for a year now. It reports an error about being unable to open appstream://org.kde.yakuake because it was not found in any repository. I can see that being a thing on the steamdeck, as that relies on the flathub repo, but for ubuntu, that caught me as odd.
Comment 4 Nicolas Fella 2022-08-25 15:15:28 UTC
I see what the problem is. The appstream id of Yakuake is org.kde.yakuake.desktop, therefore the correct URL would be appstream://org.kde.yakuake.desktop

Using that URL Discover properly finds Yakuake on KUbuntu 22.04. That suggests that the website just produces the wrong URL

Newer versions of Discover seem to handles this better though, i.e. appstream://org.kde.yakuake work, even though it is not technically correct
Comment 6 Nicolas Fella 2022-08-25 15:35:04 UTC
The second should have been https://invent.kde.org/plasma/discover/-/merge_requests/313