Bug 457589 - Changes made in Network Speed widget in the panel does not persist after computer restart.
Summary: Changes made in Network Speed widget in the panel does not persist after comp...
Status: RESOLVED DUPLICATE of bug 454004
Alias: None
Product: plasma-systemmonitor
Classification: Plasma
Component: general (show other bugs)
Version: 5.25.4
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-08-07 14:20 UTC by Subham Poddar
Modified: 2022-08-08 13:49 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Subham Poddar 2022-08-07 14:20:02 UTC
SUMMARY

Changes made in Network Speed widget in the panel does not persist after restart of the computer. I right click on Network Speed widget and click on Configure Network Speed . And then change Display Style to Text Only and choose Download Rate (B/s) in Sensors in Sensors Details. Now Network Speed widget displays Download with speed in the panel. But after restart , the Network Speed Widget's Display Style is back to default value , that is Line Chart.

STEPS TO REPRODUCE
1. Add Network Speed Widget in the panel.
2. Open Network Speed Settings window by right click on widget then Configure Network Speed.
3. Change Display Style to Text Only and choose Download Rate (B/s) in Sensors in Sensors Details.
4. Restart the computer.

OBSERVED RESULT
Changes made does not persist and values are back to default.

EXPECTED RESULT
Changes made should persist.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 5.25.4
(available in About System)
KDE Plasma Version: 5.25.4
KDE Frameworks Version: 5.96.0
Qt Version: 5.15.5

ADDITIONAL INFORMATION
Kernel Version: 5.18.16-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i3-7020U CPU @ 2.30GHz
Memory: 3.8 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 620
Manufacturer: HP
Product Name: HP Laptop 15-bs0xx
Comment 1 Subham Poddar 2022-08-07 14:28:46 UTC
Sorry I forgot to mention that after changing Display Style to Text Only , I remove Download Rate and Upload Rate Sensors and then add Download Rate (B/s) in Sensors
Comment 2 Patrick Silva 2022-08-08 13:49:54 UTC

*** This bug has been marked as a duplicate of bug 454004 ***