Bug 457081 - Create Copy of Existing doesn't clear filepath.
Summary: Create Copy of Existing doesn't clear filepath.
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: File formats (show other bugs)
Version: 5.0.6
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Dmitry Kazakov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-07-24 15:52 UTC by wolthera
Modified: 2022-07-26 11:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wolthera 2022-07-24 15:52:19 UTC
SUMMARY
Create copy of exisiting document doesn't clear the file path, which means that pressing save will just save over the original document. This makes the function identical to opening and saving the same file, while the function should actually be identical to "open existing document as new" but then for a document that's already open.

https://bugs.kde.org/show_bug.cgi?id=348256 was the original request for this functionality, it looks like it was just an oversight.


STEPS TO REPRODUCE
1. Open a file.
2. File->create copy from existing file.
3. Change something.
4. save.

OBSERVED RESULT
The document just saves over the original path.

EXPECTED RESULT
A save file dialog should pop up.
Comment 1 Dmitry Kazakov 2022-07-26 11:23:31 UTC
Git commit dcfd7aac052e2f7d35c07be97d03b6c1ae169995 by Dmitry Kazakov.
Committed on 26/07/2022 at 11:23.
Pushed by dkazakov into branch 'master'.

Fix filepath reset on "create copy from existing" action

M  +1    -0    libs/ui/KisViewManager.cpp

https://invent.kde.org/graphics/krita/commit/dcfd7aac052e2f7d35c07be97d03b6c1ae169995
Comment 2 Dmitry Kazakov 2022-07-26 11:23:35 UTC
Git commit faa8f78ce4cde90d17f9e5e8f686b791592359fa by Dmitry Kazakov.
Committed on 26/07/2022 at 11:23.
Pushed by dkazakov into branch 'krita/5.1'.

Fix filepath reset on "create copy from existing" action

M  +1    -0    libs/ui/KisViewManager.cpp

https://invent.kde.org/graphics/krita/commit/faa8f78ce4cde90d17f9e5e8f686b791592359fa