Bug 456991 - Searching in Kickoff: Selected item in list not necessarily the first one, but the one where the cursor was located before
Summary: Searching in Kickoff: Selected item in list not necessarily the first one, bu...
Status: RESOLVED DUPLICATE of bug 454349
Alias: None
Product: plasmashell
Classification: Plasma
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.25.3
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-07-21 18:38 UTC by postix
Modified: 2022-07-22 18:20 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot (672.47 KB, image/png)
2022-07-21 18:38 UTC, postix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description postix 2022-07-21 18:38:10 UTC
Created attachment 150796 [details]
Screenshot

STEPS TO REPRODUCE
1. Put your cursor somewhere, where the item list of Kickoff's search result appears
2. Hit Meta to open Kickoff
3. Hit Meta again to close Kickoff
4. Move the cursor somewhere else, outside of Kickoff's region
5. Hit Meta to open Kickoff
6. Search something by simply typing some text

OBSERVED RESULT
The search result appears and the first item is selected for a fraction of a second -- but then the item becomes selected, where in step 4 the cursor was located.


EXPECTED RESULT
Always select the first item, unless the cursor really hovers of a different item in the list.


SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20220719
KDE Plasma Version: 5.25.3
KDE Frameworks Version: 5.96.0
Qt Version: 5.15.5
Kernel Version: 5.18.11-1-default (64-bit)
Graphics Platform: Wayland
Comment 1 postix 2022-07-21 18:41:54 UTC
This bug is not only weird, but also super annoying, because it has made me open the wrong files sometimes, since I already was about pressing enter, when the selection changed by itself in a split second.
Comment 2 Nate Graham 2022-07-22 18:20:09 UTC

*** This bug has been marked as a duplicate of bug 454349 ***