Bug 456466 - SystemTray App Strawberry Middle Click To PlayPause Is Ignored After Plasma 5.25 Update
Summary: SystemTray App Strawberry Middle Click To PlayPause Is Ignored After Plasma 5...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: System Tray (show other bugs)
Version: 5.25.0
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-07-08 00:46 UTC by Chris Holland
Modified: 2022-07-13 17:35 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Holland 2022-07-08 00:46:07 UTC
At first, I thought it might be a Strawberry (Qt5 Clementine Fork) bug. After testing the Plasma/5.24 plasmoid code, I noticed middle click was working in plasmawindowed. So it's definitely a system tray regression.

My Test Script: https://gist.github.com/Zren/b605e15697745adcd52b0982ce05e527

Here's a diff of Plasma 5.24 => 5.25: https://gist.github.com/Zren/a49a07f98b95c01a63f4ac12277bb7bd
git diff Plasma/5.24 Plasma/5.25 -- ~/kde/src/plasma-workspace/applets/systemtray/

The bug is probably in one of these files:

* https://invent.kde.org/plasma/plasma-workspace/-/blame/master/applets/systemtray/package/contents/ui/items/StatusNotifierItem.qml
* https://invent.kde.org/plasma/plasma-workspace/-/blame/master/applets/systemtray/package/contents/ui/items/AbstractItem.qml
* https://invent.kde.org/plasma/plasma-workspace/-/commits/master/applets/systemtray
Comment 1 Chris Holland 2022-07-08 00:57:37 UTC
Well the "StatusNotifierItem.qml:74: TypeError: Property 'operationDescription' of object NaN is not a function" warning made it obvious that I was blind when skimming the code.

https://invent.kde.org/plasma/plasma-workspace/-/blame/master/applets/systemtray/package/contents/ui/items/StatusNotifierItem.qml#L69-70

Looks like this commit defined the service variable after the operation call accidentally when moving stuff around.

            var operation = service.operationDescription("SecondaryActivate");
            let service = model.Service;

https://invent.kde.org/plasma/plasma-workspace/-/commit/8031139aeb7f412ff3f8b9d7b1bd1d2fa16e7a2b#a3d37774fcfbf0224e15156bfd485eb9438664c1_71_70
Comment 2 Patrick Silva 2022-07-08 14:12:19 UTC
Can confirm on Arch Linux (Plasma 5.25.2) and neon unstable.
Comment 3 Bug Janitor Service 2022-07-08 15:42:02 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1904
Comment 4 Chris Holland 2022-07-09 01:30:18 UTC
Git commit b3943ee1a63c96e48f7a0706d8296b67aaf5ba1e by Chris Holland.
Committed on 08/07/2022 at 15:35.
Pushed by cholland into branch 'master'.

Fix StatusNotifierItem MidClick

Bug was introduced in !1798's 8031139a commit.

M  +1    -1    applets/systemtray/package/contents/ui/items/StatusNotifierItem.qml

https://invent.kde.org/plasma/plasma-workspace/commit/b3943ee1a63c96e48f7a0706d8296b67aaf5ba1e
Comment 5 Fushan Wen 2022-07-09 04:25:54 UTC
Git commit 627d6ab6772bd4088107dbb642871996221a7e92 by Fushan Wen, on behalf of Chris Holland.
Committed on 09/07/2022 at 04:23.
Pushed by fusionfuture into branch 'Plasma/5.25'.

Fix StatusNotifierItem MidClick

Bug was introduced in !1798's 8031139a commit.
FIXED=IN: 5.25.3
(cherry picked from commit b3943ee1a63c96e48f7a0706d8296b67aaf5ba1e)

M  +2    -2    applets/systemtray/package/contents/ui/items/StatusNotifierItem.qml

https://invent.kde.org/plasma/plasma-workspace/commit/627d6ab6772bd4088107dbb642871996221a7e92