Bug 456391 - broken/nonexistent keyboard layout
Summary: broken/nonexistent keyboard layout
Status: REPORTED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Keyboard Layout (show other bugs)
Version: 5.25.2
Platform: Neon Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-07-06 10:13 UTC by David Chmelik
Modified: 2023-06-08 10:19 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:
butirsky: Wayland-
butirsky: X11+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Chmelik 2022-07-06 10:13:53 UTC
SUMMARY
KDE system-tray used to have keyboard layout but currently has almost all past functionality removed (no customization) including icon never even displays in system-tray under any circumstances/settings!

STEPS TO REPRODUCE
1. Edit 'system tray: keyboard layout:' add layouts including alternative/international option such as 'with dead keys' for a country/language/locale (UK, USA, maybe Germany, etc.) Try to customize text & flag labels to distinguish alternative/international layout (maybe usi, uki, whatever de/Deutsch/Austrian variant label: ) can't.
2. Set keyboard layout 'always show' (or 'show when relevant' or 'always hidden' but for either of latter two cases, subsequently make/test your own steps.)
3. See nothing work nor even keyboard layout icon display in system-tray!

OBSERVED RESULT
KDE system-tray used to have keyboard layout but currently has almost all past functionality removed (no customization) including icon never even displays in system-tray under any circumstances/settings!

EXPECTED RESULT
KDE system-tray keyboard layout should have improvements including all past functionality: firstly, display in system-tray! Secondly, allow customizing text labels such as for multiple dialect layouts, and preferably over flag (but because some are for international character set usage, allowing alternative flags would be good, for example I use USA default and international layouts, latter only for British English character set so want Union Jack (UK) but someone else might want one of many English dialect/country/locale options) as (bug 444864) previously worked.  Don't require more than one spare layout (sure, family members who studied/majored in several languages use many, but I don't so want all my one to three extra layouts all set 'spare,' because so far may set but not use a fourth, and only rarely use a third, and want to avoid accidentally selecting the second (unless can have Union Jack) so currently want to forcing drop-down-select even second and all ojher spares.)

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: KDE Neon User 5.25.2 (earlier,) Slackware64 15.1-current (up-to-date.)
KDE Plasma Version: 5.25.2
KDE Frameworks Version: 5.95.0
Qt Version: 5.15 (earlier) to 5.15.5 (as of which mostly fixed for KDE Neon User)

ADDITIONAL INFORMATION
System-tray icon displays again in KDE Neon User 5.25.2 as of newer minor version (apparently unspecified, non-findable?) that upgraded to Qt 5.15.5 (so presumably icon will display after Slackware-current update (still on KDEP 5.25.2, Qt 5.15.3)) but our KDE Neon PCs have old custom label 'usi'--now unchangeable--so currently if someone adds alternative/international layout presumably can't customize to distinguish from main, but this detail (and others) could be added to bug 444864.
Comment 1 David Chmelik 2022-07-06 10:16:05 UTC
EXPECTED RESULT
'... want to forcing drop-down-select even second and all [other] spares.'
Comment 2 Nate Graham 2022-07-06 15:52:03 UTC
Please don't report multiple bugs or feature requests in a single bugzilla ticket. See https://community.kde.org/Get_Involved/Issue_Reporting#Multiple_issues_in_a_single_Bugzilla_ticket

Does the tray icon show up if you restart the computer?
Comment 3 David Chmelik 2022-07-17 01:57:35 UTC
(In reply to Nate Graham from comment #2)
> Does the tray icon show up if you restart the computer?

Neither on Neon nor Slackware.
Comment 4 David Chmelik 2022-07-17 02:04:36 UTC
(In reply to Nate Graham from comment #2)
> Does the tray icon show up if you restart the computer?

I see does on one older Neon PC with a Dell USB 104-key keyboard and IBM PS/2 model M 101-key, which the latter is on main family PC (no layout detected) and mine, which, mine, however, is plugged into a Belkin KVM switch detected (lsusb) as 'Belkin Components F5U120-PC Dual PS/2 Ports / F5U118-UNV ADB Adapter' except temporarily plugged-in with KVM switch's USB connector (for keyboard & mouse.)

I thought hardware detection is a matter of the Linux kernel but seems KDE usually (in our cases) isn't getting full information from it or started ignoring pre-GUI OS standard keyboards.
Comment 5 Nate Graham 2022-07-19 15:27:31 UTC
Andrey, can I ask you to take over on this bug report?
Comment 6 Andrey 2022-07-19 20:46:51 UTC
(In reply to David Chmelik from comment #0)
> STEPS TO REPRODUCE
> 1. Edit 'system tray: keyboard layout:' add layouts including
> alternative/international option such as 'with dead keys' for a
> country/language/locale (UK, USA, maybe Germany, etc.) Try to customize text
> & flag labels to distinguish alternative/international layout (maybe usi,
> uki, whatever de/Deutsch/Austrian variant label: ) can't.
> 2. Set keyboard layout 'always show' (or 'show when relevant' or 'always
> hidden' but for either of latter two cases, subsequently make/test your own
> steps.)
> 3. See nothing work nor even keyboard layout icon display in system-tray!
- Is 1. essential for 3?
- "Edit 'system tray: keyboard layout:' add layouts"
What do you mean exactly?
- "Set keyboard layout 'always show'" - what if it's already set?
- Can you reproduce on KDE Plasma Version: 5.24.80?
Comment 7 Andrey 2022-07-19 20:53:16 UTC
Wayland?
Comment 8 David Chmelik 2022-07-20 00:53:39 UTC
(In reply to Andrey from comment #6)
> - Is 1. essential for 3?

I think only step two is necessary.

> - Can you reproduce on KDE Plasma Version: 5.24.80?

We only use KDEP 5.25 on PCs with standard 101-key keyboards (keyboard layout systemtray icon used to work for but now doesn't) (and 5.25 on PC that has 101-key and 104-key keyboards and keyboard layout icon appears on (unless 101-key keyboard is unplugged, I presume)) but if there will be KDE Neon User LTS we can downgrade/reinstall.

(In reply to Andrey from comment #7)
> Wayland?

No.
Comment 9 Andrey 2022-07-20 07:31:49 UTC
> (In reply to Andrey from comment #7)
> > Wayland?
> 
> No.
Can you reproduce on wayland?
Comment 10 David Chmelik 2022-07-21 02:10:44 UTC
(In reply to Andrey from comment #9)
> Can you reproduce on wayland?

On family PC with only 101-key IBM model M keyboard with Wayland, the icon for keyboard layout icon reappears but has so many other problems (including some found after the test) they won't be able to use it.  I want to avoid Wayland on my own PC but would like keyboard layout to work as used to in X Window System.
Comment 11 Andrey 2022-07-26 17:07:19 UTC
I wonder if https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/951 might be related, can you test?
Comment 12 David Chmelik 2022-08-02 03:01:13 UTC
I don't entirely understand merge request 951 but are you saying may be result of (dis)connecting devices?  When I boot I almost never (dis)connect something, not even external boot drive/disc, but haven't had keyboard layout icon for maybe 1+ years anyway so (as 99% happens without (dis)connecting devices) seems my bug is more than just what's in merge request 951 but don't understand it enough to know whether what I reported is related/superset to 951.
Comment 13 Andrey 2022-08-11 17:00:05 UTC
Please check if it's related with bug 449531
Comment 14 David Chmelik 2022-08-11 18:07:55 UTC
(In reply to Andrey from comment #13)
> Please check if it's related with bug 449531

It's not because I don't personally use Wayland (only lately family PC does but Wayland has many more its own problems).
        The bug is in X with101-key keyboards (at least obscure ones including PS/2 and that type connected from obscure KVM switches that convert them to USB, all described in more detail earlier).
Comment 15 Bug Janitor Service 2022-08-26 04:35:39 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!