Bug 456364 - Marching ants for selection is not visible on 4k 27 inch screen
Summary: Marching ants for selection is not visible on 4k 27 inch screen
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Tools/Selection (show other bugs)
Version: 5.1.0-beta1
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Halla Rempt
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-07-05 19:36 UTC by Hologram
Modified: 2022-07-12 11:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Systeminfo (6.95 KB, text/plain)
2022-07-06 09:02 UTC, Hologram
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hologram 2022-07-05 19:36:26 UTC
SUMMARY
***
I have been experiencing major difficulties using Krita, since I cannot see my selection well. Depending on the background, I can sometimes guess that something is selected, but I cannot really see it. This is because the Marching ants do not scale with High DPI screens. 
***

STEPS TO REPRODUCE
1. Perform a selection with medium grey background

OBSERVED RESULT
The marching ants are almost entirely neutralised by the colour of the background. This is especially clear in the recording below:
![2022-06-23 13-45-50|video](upload://uvh2qNSPneLB3mcUEuefAOLeNNZ.mp4)

SOFTWARE/OS VERSIONS
Windows: 10.19044

ADDITIONAL INFORMATION
Also mentioned here: https://krita-artists.org/t/display-selection-highlight-size-setting/32353/18

P.S. For follow up, it may be better to tag me there, since I will be checking over on the forums more often.
Comment 1 Halla Rempt 2022-07-06 08:53:52 UTC
I worked on this before, made the ants longer, but deevad couldn't work with that, so that got reverted.
Comment 2 Halla Rempt 2022-07-06 08:56:40 UTC
Could you please also attach the contents of help->system information for bug reports?
Comment 3 Hologram 2022-07-06 09:02:42 UTC
Created attachment 150434 [details]
Systeminfo

Earlier on in the Krita-artists thread, Deevad made a suggestion to have a DPI sensitive solution, see: https://krita-artists.org/t/display-selection-highlight-size-setting/32353/14
Comment 4 Hologram 2022-07-06 09:05:50 UTC
(In reply to Halla Rempt from comment #1)
> I worked on this before, made the ants longer, but deevad couldn't work with
> that, so that got reverted.
Yes I recall that. 

To me, the issue is not necessarily only about the length of the marching ants. Their width is also too small for me to actually notice them (as you may be able to tell from the video I posted on Krita-artists, so I would personally prefer to see an increase in both length and width of the marching ants.
Comment 5 Bug Janitor Service 2022-07-06 11:33:09 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/krita/-/merge_requests/1505
Comment 6 Dmitry Kazakov 2022-07-12 11:47:27 UTC
Git commit 88d9cb822e61d202cb9fa7b997dd375aa9e7aae9 by Dmitry Kazakov, on behalf of Halla Rempt.
Committed on 12/07/2022 at 11:47.
Pushed by dkazakov into branch 'master'.

Set the size of the marching ants based on the dpi of the screen

This also handles moving the Krita window from screen to screen and
interactively changing the resolution of the screen.

M  +63   -7    libs/ui/kis_selection_decoration.cc
M  +8    -0    libs/ui/kis_selection_decoration.h

https://invent.kde.org/graphics/krita/commit/88d9cb822e61d202cb9fa7b997dd375aa9e7aae9
Comment 7 Dmitry Kazakov 2022-07-12 11:52:13 UTC
Git commit f1e5035d59102f6a9c6eac8896cc202745dae31b by Dmitry Kazakov, on behalf of Halla Rempt.
Committed on 12/07/2022 at 11:52.
Pushed by dkazakov into branch 'krita/5.1'.

Set the size of the marching ants based on the dpi of the screen

This also handles moving the Krita window from screen to screen and
interactively changing the resolution of the screen.


(cherry picked from commit 88d9cb822e61d202cb9fa7b997dd375aa9e7aae9)

M  +63   -7    libs/ui/kis_selection_decoration.cc
M  +8    -0    libs/ui/kis_selection_decoration.h

https://invent.kde.org/graphics/krita/commit/f1e5035d59102f6a9c6eac8896cc202745dae31b