Bug 456331 - Arrow keys cannot cross monitor borders
Summary: Arrow keys cannot cross monitor borders
Status: RESOLVED DUPLICATE of bug 455783
Alias: None
Product: kwin
Classification: Plasma
Component: effects-overview (show other bugs)
Version: 5.25.2
Platform: OpenSUSE Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-07-04 16:37 UTC by zerocostabstraction
Modified: 2022-07-05 18:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zerocostabstraction 2022-07-04 16:37:53 UTC
SUMMARY


STEPS TO REPRODUCE
1. Enter the overview effect (although it happens in the present all windows effect too)
2. Use arrows to move around
3. When you reach monitor border (so for example if you have a monitor to the right, pressing right arrow key on right-most window will not focus the window on the other monitor)



OBSERVED RESULT

Moving in a direction stops when the edge window is reached.

EXPECTED RESULT

Focus crosses into the other monitor, and lets me pick windows through arrow keys there.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20220701
KDE Plasma Version: 5.25.2
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.5
Kernel Version: 5.18.6-1-default (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 5800X 8-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon RX Vega
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: B450 AORUS ELITE

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2022-07-05 18:17:16 UTC

*** This bug has been marked as a duplicate of bug 455783 ***