Bug 456330 - Pressing the enter key doesn't focus the only matching window, if that window is on the other monitor
Summary: Pressing the enter key doesn't focus the only matching window, if that window...
Status: RESOLVED DUPLICATE of bug 455783
Alias: None
Product: kwin
Classification: Plasma
Component: effects-present-windows (show other bugs)
Version: 5.25.2
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-07-04 16:29 UTC by zerocostabstraction
Modified: 2022-07-05 18:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zerocostabstraction 2022-07-04 16:29:33 UTC
SUMMARY

Should be pretty clear from the title. This makes you reach for the mouse which I doubt is intended.


STEPS TO REPRODUCE
1. Enter present all window effect
2. Type in the search query of a window that only exists on the other monitor
3. Press enter or arrow keys, like you would if you were filtering on the same monitor

OBSERVED RESULT

Window isn't focused.

EXPECTED RESULT

Window should be focused, like the old effect.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20220701
KDE Plasma Version: 5.25.2
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.5
Kernel Version: 5.18.6-1-default (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 5800X 8-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon RX Vega
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: B450 AORUS ELITE
Comment 1 Nate Graham 2022-07-05 18:17:05 UTC

*** This bug has been marked as a duplicate of bug 455783 ***