Bug 456274 - Trying to apply lower resolution when 1920×1080 is set
Summary: Trying to apply lower resolution when 1920×1080 is set
Status: RESOLVED DUPLICATE of bug 455477
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi, usability, wayland
Depends on:
Blocks:
 
Reported: 2022-07-03 11:30 UTC by Nathanaël B.
Modified: 2022-07-03 20:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nathanaël B. 2022-07-03 11:30:41 UTC
Application: systemsettings (5.25.1)

Qt Version: 5.15.5
Frameworks Version: 5.95.0
Operating System: Linux 5.18.6-1-default x86_64
Windowing System: Wayland
Distribution: "openSUSE Tumbleweed"
DrKonqi: 5.25.1 [KCrashBackend]

-- Information about the crash:
The monitor was set to 1920×1080 (its native resolution seems to be 1360×768), and trying to apply a 1366×768, 1280×1024 or 1280×800 resolution make systemsettings crash. The other resolutions don’t make it crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Configuration du système (systemsettings), signal: Segmentation fault

[KCrash Handler]
#4  0x00007ff9f8ec4580 in KScreen::Mode::id() const () from /lib64/libKF5Screen.so.7
#5  0x00007ff9f8f5abd7 in ?? () from /usr/lib64/qt5/plugins/kcms/kcm_kscreen.so
#6  0x00007ffa1e051b25 in QQmlDMAbstractItemModelData::setValue (value=..., role=267, this=0x5617e81e8460) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/qmlmodels/qqmladaptormodel.cpp:421
#7  QQmlDMCachedModelData::metaCall (this=0x5617e81e8460, call=<optimized out>, id=<optimized out>, arguments=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/qmlmodels/qqmladaptormodel.cpp:298
#8  0x00007ffa1efce624 in QQmlPropertyData::writeProperty (flags=..., value=<optimized out>, target=<optimized out>, this=<optimized out>) at ../../include/QtQml/5.15.5/QtQml/private/../../../../../../src/qml/qml/qqmlpropertydata_p.h:379
#9  QQmlPropertyPrivate::write (object=object@entry=0x5617e81e8460, property=..., value=..., context=0x5617e8028b60, flags=..., flags@entry=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/qml/qml/qqmlproperty.cpp:1309
#10 0x00007ffa1eef3085 in QV4::QObjectWrapper::setProperty (engine=0x5617e7fd78f0, object=0x5617e81e8460, property=0x5617e83fe798, value=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:565
#11 0x00007ffa1eef3dab in QV4::QObjectWrapper::setQmlProperty (engine=engine@entry=0x5617e7fd78f0, qmlContext=<optimized out>, object=0x5617e81e8460, name=<optimized out>, revisionMode=revisionMode@entry=QV4::QObjectWrapper::IgnoreRevision, value=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:435
#12 0x00007ffa1eef3f0b in QV4::QObjectWrapper::virtualPut (m=0x7ff9f8968588, id=..., value=..., receiver=0x7ff9f8968588) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:722
#13 0x00007ffa1ee7c9c3 in QV4::Object::put (receiver=0x7ff9f8968588, v=..., name=0x7ff9f8968590, this=0x7ff9f8968588) at ../../include/QtQml/5.15.5/QtQml/private/../../../../../../src/qml/jsruntime/qv4string_p.h:167
#14 QV4::Lookup::setterFallback (l=<optimized out>, engine=0x5617e7fd78f0, object=..., value=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/qml/jsruntime/qv4lookup.cpp:497
#15 0x00007ffa1ef0e2d4 in QV4::Moth::VME::interpret (frame=0x7ffc0b19f928, engine=0x5617e7fd78f0, code=0x7ff9f874fb39 "\016\002") at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/qml/jsruntime/qv4vme_moth.cpp:351
#16 0x00007ffa1ef1232f in QV4::Moth::VME::exec (frame=frame@entry=0x7ffc0b19ff30, engine=engine@entry=0x5617e7fd78f0) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/qml/jsruntime/qv4vme_moth.cpp:466
#17 0x00007ffa1eea52ce in QV4::Function::call (this=this@entry=0x5617e7f46c30, thisObject=<optimized out>, argv=argv@entry=0x7ff9f8968508, argc=<optimized out>, context=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/qml/jsruntime/qv4function.cpp:69
#18 0x00007ffa1f02d3fd in QQmlJavaScriptExpression::evaluate (this=this@entry=0x5617e8cb5a70, callData=callData@entry=0x7ff9f89684d8, isUndefined=isUndefined@entry=0x0) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/qml/qml/qqmljavascriptexpression.cpp:212
#19 0x00007ffa1efdee5f in QQmlBoundSignalExpression::evaluate (this=<optimized out>, a=<optimized out>) at ../../include/QtQml/5.15.5/QtQml/private/../../../../../../src/qml/jsruntime/qv4jscall_p.h:95
#20 0x00007ffa1efe0038 in QQmlBoundSignal_callback (e=0x5617e8cb5a20, a=0x7ffc0b1a1b60) at ../../include/QtQml/5.15.5/QtQml/private/../../../../../../src/qml/qml/qqmlboundsignalexpressionpointer_p.h:69
#21 0x00007ffa1f01274f in QQmlNotifier::emitNotify (endpoint=<optimized out>, a=0x7ffc0b1a1b60) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/qml/qml/qqmlnotifier.cpp:104
#22 0x00007ffa2130c9ad in doActivate<false> (sender=0x5617e82c2650, signal_index=61, argv=0x7ffc0b1a1b60) at kernel/qobject.cpp:3778
#23 0x00007ffa2130622f in QMetaObject::activate (sender=<optimized out>, m=<optimized out>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffc0b1a1b60) at kernel/qobject.cpp:3946
#24 0x00007ffa1b9b8cde in QQuickComboBox::activated (this=<optimized out>, _t1=<optimized out>) at .moc/moc_qquickcombobox_p.cpp:759
#25 0x00007ffa1b93f1de in QQuickComboBoxPrivate::setCurrentIndex (activate=(anonymous namespace)::Activate, index=2, this=0x5617e7737830) at /usr/src/debug/libqt5-qtquickcontrols2-5.15.5+kde5-1.1.x86_64/src/quicktemplates2/qquickcombobox.cpp:536
#26 QQuickComboBoxPrivate::incrementCurrentIndex (this=0x5617e7737830) at /usr/src/debug/libqt5-qtquickcontrols2-5.15.5+kde5-1.1.x86_64/src/quicktemplates2/qquickcombobox.cpp:549
#27 0x00007ffa1f44ec58 in QQuickItem::event (this=0x5617e82c2650, ev=0x7ffc0b1a1d30) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/quick/items/qquickitem.cpp:8248
#28 0x00007ffa21f8e41e in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x5617e82c2650, e=0x7ffc0b1a1d30) at kernel/qapplication.cpp:3637
#29 0x00007ffa212d5fb8 in QCoreApplication::notifyInternal2 (receiver=0x5617e82c2650, event=0x7ffc0b1a1d30) at kernel/qcoreapplication.cpp:1064
#30 0x00007ffa1f46d6ab in QQuickWindowPrivate::deliverSinglePointEventUntilAccepted (this=this@entry=0x5617e7e47650, event=event@entry=0x5617e8bbd9a0) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/quick/items/qquickwindow.cpp:2202
#31 0x00007ffa1f46ddeb in QQuickWindowPrivate::deliverPointerEvent (this=this@entry=0x5617e7e47650, event=0x5617e8bbd9a0) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/quick/items/qquickwindow.cpp:2621
#32 0x00007ffa1f46e03e in QQuickWindow::wheelEvent (this=<optimized out>, event=0x7ffc0b1a2150) at /usr/src/debug/libqt5-qtdeclarative-5.15.5+kde19-1.1.x86_64/src/quick/items/qquickwindow.cpp:2243
#33 0x00007ffa2184da15 in QWindow::event (this=0x5617e7ebd1c0, ev=<optimized out>) at kernel/qwindow.cpp:2438
#34 0x00007ffa21f8e41e in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x5617e7ebd1c0, e=0x7ffc0b1a2150) at kernel/qapplication.cpp:3637
#35 0x00007ffa212d5fb8 in QCoreApplication::notifyInternal2 (receiver=0x5617e7ebd1c0, event=0x7ffc0b1a2150) at kernel/qcoreapplication.cpp:1064
#36 0x00007ffa21fcfc68 in QWidget::event (this=0x5617e810ed40, event=0x7ffc0b1a2150) at kernel/qwidget.cpp:9033
#37 0x00007ffa21f8e41e in QApplicationPrivate::notify_helper (this=this@entry=0x5617e74ae730, receiver=receiver@entry=0x5617e810ed40, e=e@entry=0x7ffc0b1a2150) at kernel/qapplication.cpp:3637
#38 0x00007ffa21f971e6 in QApplication::notify (this=<optimized out>, receiver=0x5617e810ed40, e=<optimized out>) at kernel/qapplication.cpp:3189
#39 0x00007ffa212d5fb8 in QCoreApplication::notifyInternal2 (receiver=0x5617e810ed40, event=0x7ffc0b1a2310) at kernel/qcoreapplication.cpp:1064
#40 0x00007ffa21fea65b in QWidgetWindow::handleWheelEvent (this=this@entry=0x5617e76b5150, event=event@entry=0x7ffc0b1a24e0) at kernel/qwidgetwindow.cpp:888
#41 0x00007ffa21fec115 in QWidgetWindow::event (this=0x5617e76b5150, event=0x7ffc0b1a24e0) at kernel/qwidgetwindow.cpp:327
#42 0x00007ffa21f8e41e in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x5617e76b5150, e=0x7ffc0b1a24e0) at kernel/qapplication.cpp:3637
#43 0x00007ffa212d5fb8 in QCoreApplication::notifyInternal2 (receiver=0x5617e76b5150, event=0x7ffc0b1a24e0) at kernel/qcoreapplication.cpp:1064
#44 0x00007ffa2183d322 in QGuiApplicationPrivate::processWheelEvent (e=0x5617e8a33610) at kernel/qguiapplication.cpp:2368
#45 0x00007ffa2181533c in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:1169
#46 0x00007ffa1e60d780 in userEventSourceDispatch (source=<optimized out>) at qeventdispatcher_glib.cpp:74
#47 0x00007ffa1f80cea0 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#48 0x00007ffa1f80d258 in ?? () from /lib64/libglib-2.0.so.0
#49 0x00007ffa1f80d2ec in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#50 0x00007ffa2132d456 in QEventDispatcherGlib::processEvents (this=0x5617e74e0140, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#51 0x00007ffa212d4a2b in QEventLoop::exec (this=this@entry=0x7ffc0b1a2780, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#52 0x00007ffa212dcb96 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#53 0x00005617e7400e33 in ?? ()
#54 0x00007ffa20bdf5b0 in __libc_start_call_main () from /lib64/libc.so.6
#55 0x00007ffa20bdf679 in __libc_start_main_impl () from /lib64/libc.so.6
#56 0x00005617e7401745 in ?? ()
[Inferior 1 (process 2047) detached]

The reporter indicates this bug may be a duplicate of or related to bug 392001, bug 455477.

Reported using DrKonqi
This report was filed against 'kde' because the product 'systemsettings' could not be located in Bugzilla. Add it to drkonqi's mappings file!
Comment 1 Yerrey Dev 2022-07-03 20:07:58 UTC
This is Wayland only and should be fixed in 5.25.3.

*** This bug has been marked as a duplicate of bug 455477 ***