Bug 456253 - "http://127.0.0.1:4000/" no longer recognized as a single link (including the port)
Summary: "http://127.0.0.1:4000/" no longer recognized as a single link (including the...
Status: RESOLVED DUPLICATE of bug 452978
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 22.04.1
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-07-02 17:46 UTC by Ralf Jung
Modified: 2022-07-02 18:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Jung 2022-07-02 17:46:30 UTC
SUMMARY

The string "http://127.0.0.1:4000/" no longer becomes a single clickable link in Konsole. Instead it thinks the link is for "http://127.0.0.1".


STEPS TO REPRODUCE
1. "echo http://127.0.0.1:4000/"
2. Right-click on the link, "Open Link"

OBSERVED RESULT
It opens "http://127.0.0.1"

EXPECTED RESULT
It should open "http://127.0.0.1:4000/". This used to work a few months ago, so I think this is some recent regression.

SOFTWARE/OS VERSIONS
Operating System: Debian GNU/Linux
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4
Kernel Version: 5.18.0-2-amd64 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Xeon® CPU E3-1505M v5 @ 2.80GHz
Memory: 31,2 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics P530

ADDITIONAL INFORMATION
Comment 1 Ahmad Samir 2022-07-02 18:21:12 UTC

*** This bug has been marked as a duplicate of bug 452978 ***