Bug 456080 - Krita 5.1.0 beta 2 : outline brush shows square instead of brush tip shape.
Summary: Krita 5.1.0 beta 2 : outline brush shows square instead of brush tip shape.
Status: RESOLVED DUPLICATE of bug 455912
Alias: None
Product: krita
Classification: Unclassified
Component: Brush Engine/Shape (show other bugs)
Version: nightly build (please specify the git hash!)
Platform: Other Other
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-28 12:09 UTC by stephen
Modified: 2022-06-28 12:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
outline preview square (632.71 KB, image/png)
2022-06-28 12:09 UTC, stephen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stephen 2022-06-28 12:09:52 UTC
Created attachment 150226 [details]
outline preview square

SUMMARY
Krita version is 5.1.0 beta2(git 5f298d4)
After the fix of huge performance drop with complex
brush tips, the outline preview, started to show either literal squares
or rectangle for some custom brush tips.
This is an example. And I don't know why this is happening.
Given that one of the most complex brush tips I have stills show up
correctly, I don't think the brush tip's complexity is the issue.
But anyway. Reporting this for eventual investigation. 

STEPS TO REPRODUCE
1.  Select Krita's chalk brush tip to customize one of your pixel engine brushes
2. stay in focus on your canvas and move the cursor around

OBSERVED RESULT.
The outline of the cursor shows a square rather than the brush shape.

EXPECTED RESULT
We should observe the shape of the brush tip instead of the square.

SOFTWARE/OS VERSIONS
Windows: 10 21H1
Comment 1 wolthera 2022-06-28 12:12:40 UTC

*** This bug has been marked as a duplicate of bug 455912 ***