Bug 455891 - GMIC:Cannot use 'curves' filter more than once
Summary: GMIC:Cannot use 'curves' filter more than once
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: G'Mic for Krita (show other bugs)
Version: 5.1.0-beta1
Platform: Other Other
: NOR normal
Target Milestone: ---
Assignee: Dmitry Kazakov
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2022-06-24 15:44 UTC by thetwo
Modified: 2022-07-12 15:15 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
pic (280.66 KB, image/png)
2022-06-24 15:44 UTC, thetwo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thetwo 2022-06-24 15:44:40 UTC
Created attachment 150119 [details]
pic

STEPS TO REPRODUCE
1. Use the "curves" filter on a picture
2. Use the "curves" filter again

If you do not switch the "colorspace" of the filter, it cannot be used again, including the contents of the new layer
Comment 1 amyspark 2022-07-04 22:52:14 UTC
Confirming with G'MIC 3.1.5 (commit 06d2048) and Krita 5.2.0 prealpha (commit 76a9e434dd). We're returning an empty image set immediately upon application.

> If you do not switch the "colorspace" of the filter, it cannot be used again, including the contents of the new layer

Alternatively, changing input modes makes it work again.
Comment 2 amyspark 2022-07-04 23:58:53 UTC
Turning over to Dmitry.

This is related to commit c5007a7bbfdfd66b165fdf1231435a41e40ce1e1. In the case where Krita has received an image back, the cropped image request immediately after will fail on the tryBarrierLock call.  The provided workaround (re-requesting a redraw) never takes effect because PreviewWidget::paintOriginalImage is never reached via MainWindow::onPreviewUpdateRequested.
Comment 3 Dmitry Kazakov 2022-07-12 11:17:05 UTC
A fix will be delivered with this MR: https://github.com/amyspark/gmic/pull/4
Comment 4 Bug Janitor Service 2022-07-12 13:57:14 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/krita/-/merge_requests/1516
Comment 5 amyspark 2022-07-12 15:14:41 UTC
Git commit 3057cae40229c112955f1a335bd1bac3d37fa3b3 by L. E. Segovia.
Committed on 12/07/2022 at 15:14.
Pushed by lsegovia into branch 'master'.

G'MIC: update to 3.1.4.3

M  +2    -2    3rdparty_plugins/ext_gmic/CMakeLists.txt [INFRASTRUCTURE]

https://invent.kde.org/graphics/krita/commit/3057cae40229c112955f1a335bd1bac3d37fa3b3
Comment 6 amyspark 2022-07-12 15:15:37 UTC
Git commit 4749939985a3083bc355d193ca555e4402eec2a9 by L. E. Segovia.
Committed on 12/07/2022 at 15:15.
Pushed by lsegovia into branch 'krita/5.1'.

G'MIC: update to 3.1.4.3
(cherry picked from commit 3057cae40229c112955f1a335bd1bac3d37fa3b3)

M  +2    -2    3rdparty_plugins/ext_gmic/CMakeLists.txt [INFRASTRUCTURE]

https://invent.kde.org/graphics/krita/commit/4749939985a3083bc355d193ca555e4402eec2a9