Bug 455790 - Present windows effect no longer filters windows on all monitors
Summary: Present windows effect no longer filters windows on all monitors
Status: RESOLVED DUPLICATE of bug 455783
Alias: None
Product: kwin
Classification: Plasma
Component: effects-present-windows (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-22 14:52 UTC by Carlos Colorado
Modified: 2022-06-22 16:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screeenshot of the current present windows filtering behaviour (553.80 KB, image/png)
2022-06-22 14:52 UTC, Carlos Colorado
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Colorado 2022-06-22 14:52:14 UTC
Created attachment 150054 [details]
Screeenshot of the current present windows filtering behaviour

SUMMARY
***
When the effect Present windows were activated, the user could type and filter for windows across all monitors. 
After the latest updates (archlinux package: kwin-5.25.0-2, kwin-5.25.1-1), the default behavior of the effect filters only windows contained on the monitor where the mouse is currently positioned.

Looking at the now minified present window configuration tool I find no indication that this new behavior is in any way configurable. 
(System Settings > Workspace Behavior > Desktop Effects > Present Windows > [settings button]) 

New behavior is highly inconvenient, since before filtering could help you locate and focus a window, no matter where it was, and most importantly without having to get distracted recognizing window thumbnails. 
***


STEPS TO REPRODUCE
1. Have multiple monitos
2. Distribute windows of the same app across your monitors (e.g. browser windows)
3. Activate the present windows effect
4. Type a partial name of a window preferably of an app non on your current active monitor (where your mouse pointer is).
 

OBSERVED RESULT
Filter only hides the windows not matching the filtering string but only on the monitor where your mouse is located, instead of all the monitors. 

EXPECTED RESULT
Filter should have hidden all windows on all monitors that match your filter query.
Filtering a window shouldn't require locating the mouse to the specific monitor to redo the filtering.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 

Linux/KDE Plasma: 5.25.1
(available in About System)
KDE Plasma Version: 5.25.1  
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.5

ADDITIONAL INFORMATION
Kwin version: 5.25.1
qt5-graphicaleffects: 5.15.5+kde+r0-1
Linux Kernel version: 5.18.3-arch1-1

Attached screenshot highlighting:
* Present window NEW search bar (before it was just sort of a floating text label) 
* mouse current position
* window matching the title of the search bar.
Comment 1 Nate Graham 2022-06-22 16:24:11 UTC

*** This bug has been marked as a duplicate of bug 455783 ***