Bug 455738 - KScreenLocker with black screen after some minutes in sleep
Summary: KScreenLocker with black screen after some minutes in sleep
Status: RESOLVED DUPLICATE of bug 457284
Alias: None
Product: kscreenlocker
Classification: Plasma
Component: greeter (show other bugs)
Version: 5.25.1
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-21 17:32 UTC by Higor Silva
Modified: 2022-10-26 14:43 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
journalctl-log (15.10 KB, text/plain)
2022-06-30 06:29 UTC, Frank Kuo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Higor Silva 2022-06-21 17:32:37 UTC
Hello everyone

KScreenLocker shows black screen after some minutes of sleep (laptop). It's not showing nothing (any icon, cursor, nothing), even if I login from tty2 (CTRL + ALT + F2). It's not happens everytime, only in random times. I've searched around my journalctl and found this errors:

jun 21 13:21:46 pinguim kscreenlocker_greet[13691]: Qt: Session management error: networkIdsList argument is NULL
jun 21 13:21:47 pinguim kscreenlocker_greet[13691]: file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/>
jun 21 13:21:47 pinguim kscreenlocker_greet[13691]: file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/>
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/>
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/>
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/>
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim plasmashell[9763]: QXcbClipboard::setMimeData: Cannot set X11 selection owner
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim plasmashell[9763]: QXcbClipboard::setMimeData: Cannot set X11 selection owner
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old

I tried to run '/usr/lib/kscreenlocker_greet --testing', but it's everything fine (As I've said, the black screen thing happens randomly) with some minors errors:

file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/components/VirtualKeyboard.qml:8:1: module "QtQuick.VirtualKeyboard" is not installed
file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/lockscreen/LockScreenUi.qml:222: ReferenceError: wallpaper is not defined
Locked at 1655831997
file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/components/UserList.qml:43:9: Unable to assign [undefined] to bool 



SOFTWARE/OS VERSIONS
Linux: Arch Linux x86_64 - Kernel 5.18.5-arch1-1
KDE Plasma Version: Plasma 5.25.1
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.5

ADDITIONAL INFORMATION
It's happens in both X11 and Wayland sessions
Comment 1 Higor Silva 2022-06-21 17:40:27 UTC
Sorry, I miss something when I've copied the journalctl logs. Here is the right one

jun 21 13:21:46 pinguim kscreenlocker_greet[13691]: Qt: Session management error: networkIdsList argument is NULL
jun 21 13:21:47 pinguim kscreenlocker_greet[13691]: file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/components/VirtualKeyboard.qml:8:1: module "QtQuick.VirtualKeyboard" is not installed
jun 21 13:21:47 pinguim kscreenlocker_greet[13691]: file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/lockscreen/LockScreenUi.qml:222: ReferenceError: wallpaper is not defined
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/lockscreen/LockScreenUi.qml:604: TypeError: Value is undefined and could not be converted to an object
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/components/UserList.qml:43:9: Unable to assign [undefined] to bool
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: file:///usr/share/plasma/look-and-feel/org.kde.breeze.desktop/contents/components/UserList.qml:43:9: Unable to assign [undefined] to bool
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
jun 21 13:21:48 pinguim kscreenlocker_greet[13691]: QXcbClipboard: SelectionRequest too old
Comment 2 Frank Kuo 2022-06-30 06:29:17 UTC
Created attachment 150282 [details]
journalctl-log

Having the same issue here.
The wallpaper for lock screen isn't showed, and some effects like background blur are also gone.

------

System info:
EndeavourOS
Plasma 5.25.2
KDE Framworks 5.95.0
Qt 5.15.5
Kernel 5.15.50-1-lts

Application theme: Lightly by Luwx
Plasma style: Colloid-light by vinceliuice
Comment 3 Erich Eickmeyer 2022-10-26 14:43:48 UTC

*** This bug has been marked as a duplicate of bug 457284 ***