Bug 455689 - Turning off/ on a display after the user logins causes several issues
Summary: Turning off/ on a display after the user logins causes several issues
Status: RESOLVED DUPLICATE of bug 449957
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: 5.25.1
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-21 03:24 UTC by andresdortiz
Modified: 2022-06-29 16:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
journal with all kwin scripts disabled and latte dock closed (882.00 KB, text/x-log)
2022-06-21 03:24 UTC, andresdortiz
Details
journal primary/secondary switch. no wayland cras (809.05 KB, text/x-log)
2022-06-21 03:34 UTC, andresdortiz
Details
kwin_wayland core dump (44.31 KB, text/x-log)
2022-06-21 16:35 UTC, andresdortiz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andresdortiz 2022-06-21 03:24:32 UTC
Created attachment 149987 [details]
journal with all kwin scripts disabled and latte dock closed

SUMMARY
Issue range from primary monitor being set to secondary and secondary to primary on a dual monitor setup ( even going into display settings and changing the primary does not fix it, whatever you set to primary will be set to secondary  and vice versa) ( this is confirmed by using a kwin rule to force a window onto the primary it will be forced to the secondary instead)

Sometimes this same bug(?) will cause wayland to crash along with all your apps bringing you back to a blank desktop with nothing running


STEPS TO REPRODUCE
1. turn a display on/off after user login
2. notice either wayland crash or primary/secondary switch on a dual screen setup

OBSERVED RESULT
wayland crashes and/or primary and secondary displays get switched.

EXPECTED RESULT
turning off/on a display causes no issues

SOFTWARE/OS VERSIONS
Operating System: Garuda Linux
KDE Plasma Version: 5.25.0
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.5
Kernel Version: 5.18.5-zen1-1-zen (64-bit)
Graphics Platform: Wayland
Processors: 12 × AMD Ryzen 5 2600X Six-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon RX 6700 XT

ADDITIONAL INFORMATION
Comment 1 andresdortiz 2022-06-21 03:34:18 UTC
Created attachment 149988 [details]
journal primary/secondary switch. no wayland cras

I seemed to have uploaded the wrong journal last time here is a new one. Here the primary and secondary are being switched  but wayland is not crashing
Comment 2 Vlad Zahorodnii 2022-06-21 07:27:58 UTC
Can you get the backtrace of the crash? The backtrace can be retrieved by checking coredumpctl, e.g.

  coredumpctl list kwin_wayland

then search for relevant entry and run

 coredumpctl gdb <pid as shown in coredumpctl list>
Comment 3 andresdortiz 2022-06-21 16:35:05 UTC
Created attachment 150021 [details]
kwin_wayland core dump
Comment 4 andresdortiz 2022-06-21 16:42:13 UTC
I thought I disabled bismuth (a kwin tilling script) to see if I can get the crash without, but it's showing up in the core dumps. making sure it's disabled seems to reliably only produce the first issue of the primary/secondary swap. so the crash may be because of bismuth? Should I open an issue?
Comment 5 David Edmundson 2022-06-29 16:06:00 UTC
                #0  0x00007efe16907454 _ZNK4KWin6Output5scaleEv (libkwin.so.5 + 0x213454)
                #1  0x00007efe16907dc2 _ZNK4KWin6Output8geometryEv (libkwin.so.5 + 0x213dc2)
                #2  0x00007efe169bfe93 _ZNK4KWin9Workspace10clientAreaENS_16clientAreaOptionEPKNS_6OutputEPKNS_14VirtualDesktopE (libkwin.so.5 + 0x2cbe93)
                #3  0x00007efe16956835 n/a (libkwin.so.5 + 0x262835)
                #4  0x00007efe1573f23e _ZNK11QMetaMethod6invokeEP7QObjectN2Qt14ConnectionTypeE22QGenericReturnArgument16QGenericArgumentS5_S5_S5_S5_S5_S5_S5_S5_S5_ (libQt5Core.so.5 + 0x29c23e)

*** This bug has been marked as a duplicate of bug 449957 ***