Bug 455292 - 5.25 Desktop Grid - Can't select a virtual desktop using the keyboard anymore
Summary: 5.25 Desktop Grid - Can't select a virtual desktop using the keyboard anymore
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: effects-desktop-grid (show other bugs)
Version: 5.25.0
Platform: Archlinux Packages Linux
: VHI normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: regression, usability
: 455509 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-06-15 00:20 UTC by hugh
Modified: 2022-06-23 03:18 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hugh 2022-06-15 00:20:00 UTC
SUMMARY

New desktop grid implentation in 5.25 does not allow keyboard selection of a virtual desktop whilst in grid mode.  Only way to select is to click a desktop with the mouse.  Please add this functionality back.

STEPS TO REPRODUCE

1. Open desktop grid view.

2. Use number keys or Function keys to select a virtual desktop.

OBSERVED RESULT

Nada.  

Keyed desktop does not become active and desktop grid remains open.

EXPECTED RESULT

Desktop grid closes and selected desktop becomes active.

Previous implementation of desktop grid allowed for numerical keyboard selection (ie 1-n) and function key selection (ie F1-Fn).  Please add both these back.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Arch Linux
(available in About System)
KDE Plasma Version: 5.25
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.4

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2022-06-15 18:06:18 UTC
Can confirm.
Comment 2 galder 2022-06-18 18:41:37 UTC
*** Bug 455509 has been marked as a duplicate of this bug. ***
Comment 3 hugh 2022-06-21 00:51:32 UTC
This is not making it into 5.25.1?

As a keyboard centric user I hope this gets fixed soon.
Comment 4 Bug Janitor Service 2022-06-21 07:45:06 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kwin/-/merge_requests/2556
Comment 5 Vlad Zahorodnii 2022-06-21 08:58:59 UTC
Git commit d40aec08536c28e35824b0f17adabce3fcac2880 by Vlad Zahorodnii.
Committed on 21/06/2022 at 07:43.
Pushed by vladz into branch 'master'.

effects/desktopgrid: Allow switching between desktops using digit and function keys

C++ version allowed switching between virtual desktops by pressing
function keys (Fn) or digit keys.

M  +11   -0    src/effects/desktopgrid/qml/main.qml

https://invent.kde.org/plasma/kwin/commit/d40aec08536c28e35824b0f17adabce3fcac2880
Comment 6 Vlad Zahorodnii 2022-06-21 08:59:28 UTC
Git commit 9591c3a118b830af1864ec622ab1d233db94fbc9 by Vlad Zahorodnii.
Committed on 21/06/2022 at 08:59.
Pushed by vladz into branch 'Plasma/5.25'.

effects/desktopgrid: Allow switching between desktops using digit and function keys

C++ version allowed switching between virtual desktops by pressing
function keys (Fn) or digit keys.


(cherry picked from commit d40aec08536c28e35824b0f17adabce3fcac2880)

M  +11   -0    src/effects/desktopgrid/qml/main.qml

https://invent.kde.org/plasma/kwin/commit/9591c3a118b830af1864ec622ab1d233db94fbc9
Comment 7 hugh 2022-06-21 21:16:46 UTC
Thx.