Bug 455134 - [applets/batterymonitor] Sleep and locking continue to be blocked even after an app is closed
Summary: [applets/batterymonitor] Sleep and locking continue to be blocked even after ...
Status: RESOLVED DOWNSTREAM
Alias: None
Product: plasmashell
Classification: Plasma
Component: Battery Monitor (show other bugs)
Version: 5.24.5
Platform: openSUSE Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-10 15:04 UTC by je2
Modified: 2022-06-16 12:57 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description je2 2022-06-10 15:04:19 UTC
SUMMARY

After closing an application, there is still a message in batterymonitor that sleep and locking are blocked but the app name is missing and there is no way to clear it.

Image: https://invent.kde.org/plasma/plasma-workspace/uploads/3530c1737b00dae70d21ca16f8c48b50/image.png

So far this has happened to me twice in a row after ending a Zoom session and closing the app.  Only rebooting clears the message and wakelock.
I'm happy to try to troubleshoot if you can point me in the right direction.  Thanks.

STEPS TO REPRODUCE
1. Launch and use Zoom, a message indicating it is preventing sleep is displayed
2. Close Zoom

OBSERVED RESULT
The message "is currently blocking sleep and screen locking (webcam in use)" is still displayed, but no application name is shown and it can't be cleared.

EXPECTED RESULT
The message should disappear and sleep should return to normal.

SOFTWARE/OS VERSIONS

Operating System: openSUSE Tumbleweed 20220605
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.2
Kernel Version: 5.18.1-1-default (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-6300U CPU @ 2.40GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 520
Comment 1 Nate Graham 2022-06-14 14:48:59 UTC
Notice how the reason is still there ("Webcam in use") but the app name at the beginning of the sentence is blank.

This means that Zoom didn't properly release the webcam when it quit. This is an app bug, and you'll need to report it to the Zoom developers.
Comment 2 je2 2022-06-16 09:19:43 UTC
(In reply to Nate Graham from comment #1)
> Notice how the reason is still there ("Webcam in use") but the app name at
> the beginning of the sentence is blank.
> 
> This means that Zoom didn't properly release the webcam when it quit. This
> is an app bug, and you'll need to report it to the Zoom developers.

That does not surprise me at all... but thanks for confirming.  I will raise it with them.

In the meantime, how does Plasma get this information and is there any way to clear it without a reboot?
Comment 3 Nate Graham 2022-06-16 12:57:49 UTC
Not yet I'm afraid. See Bug 423745.