Bug 455018 - URL's containing port spec can not be ctrl-clicked correctly
Summary: URL's containing port spec can not be ctrl-clicked correctly
Status: RESOLVED DUPLICATE of bug 452978
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 22.04.1
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-08 09:02 UTC by Martin van Es
Modified: 2022-06-08 10:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin van Es 2022-06-08 09:02:30 UTC
SUMMARY
URL's containing port spec can not be ctrl-clicked correctly

STEPS TO REPRODUCE
1.  Show URL containing port spec as output in konsole e.g. echo "http://localhost:5001/test"
2.  Hover over URL
3.  Ctrl-click URL

OBSERVED RESULT
Only http://localhost underlined, missing everything after the colon :
Ctrl-clicking opens default browser on http://localhost

EXPECTED RESULT
Complete URL http://localhost:5001/test underlined, including the part after the colon :
Ctrl-clicking opens default browser on http://localhost:5001/test

SOFTWARE/OS VERSIONS
Operating System: Kubuntu 22.04
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.3
Kernel Version: 5.18.2 (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-10510U CPU @ 1.80GHz
Memory: 31.1 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics
Comment 1 Ahmad Samir 2022-06-08 10:03:39 UTC

*** This bug has been marked as a duplicate of bug 452978 ***