Bug 455004 - kded5 strictly increasing number of x11 clients
Summary: kded5 strictly increasing number of x11 clients
Status: RESOLVED DUPLICATE of bug 453280
Alias: None
Product: frameworks-kded
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.94.0
Platform: Archlinux Linux
: NOR normal
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-08 00:16 UTC by jerryrwu
Modified: 2022-06-08 07:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jerryrwu 2022-06-08 00:16:21 UTC
FYI: Not that familiar with all this... entirely possible this is user error or me interpreting it wrong.

SUMMARY
Socket is opened every time monitor turns on and never closes. I had ~180 sockets owned by kded5 at one point, preventing other applications from working properly. They start at 5 sockets on boot, and increases by 6 every time I restart my monitors. 


STEPS TO REPRODUCE
1. Power off monitor
2. Power on monitor
3. Check sockets using command: sudo ss -x src "*/tmp/.X11-unix/*" | grep -Eo "[0-9]+\s*$" | while read port; do sudo ss -p -x | grep -w $port | grep -v X11-unix ; done | grep -Eo '".+"' | sort | uniq -c | sort -rn


OBSERVED RESULT
Number of open sockets to X increase by 6.

EXPECTED RESULT
I don't know. It shouldn't just be strictly increasing though, since at some point I will run out. 

SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4
Kernel Version: 5.18.1-arch1-1 (64 bit)
Graphics Platform: X11

ADDITIONAL INFORMATION
Comment 1 Nicolas Fella 2022-06-08 07:49:08 UTC

*** This bug has been marked as a duplicate of bug 453280 ***