Bug 454957 - Active URL link in console output
Summary: Active URL link in console output
Status: RESOLVED DUPLICATE of bug 452978
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 22.04.1
Platform: Neon Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-07 08:13 UTC by Kane
Modified: 2022-06-07 09:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Not all ULR is clickable/active (22.31 KB, image/png)
2022-06-07 08:16 UTC, Kane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kane 2022-06-07 08:13:51 UTC
SUMMARY

I previous version of Konsole URL like this was handled properly: "https://gerrit.alterpage.pl:8080/c/deployer/+/4565"
now only "https://gerrit.alterpage.pl" is linked/clickable.

STEPS TO REPRODUCE
1. Print to output some URL with port in URL
2. Press Ctrl and click to URL
3. Go to "https://{domain}" instead of "https://{domain}:{port}/{path}" etc.

OBSERVED RESULT
My browser open "https://gerrit.alterpage.pl"

EXPECTED RESULT
My browser open "https://gerrit.alterpage.pl:8080/c/deployer/+/4565"

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: KDE Neon
(available in About System)
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4

ADDITIONAL INFORMATION
Comment 1 Kane 2022-06-07 08:16:09 UTC
Created attachment 149521 [details]
Not all ULR is clickable/active
Comment 2 Ahmad Samir 2022-06-07 09:07:04 UTC

*** This bug has been marked as a duplicate of bug 452978 ***