Bug 454945 - kded5 and org_kde_powerdevil crashed when turning on an external screen
Summary: kded5 and org_kde_powerdevil crashed when turning on an external screen
Status: RESOLVED DUPLICATE of bug 451028
Alias: None
Product: frameworks-kded
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.94.0
Platform: OpenSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: David Faure
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2022-06-06 21:02 UTC by postix
Modified: 2022-06-07 17:37 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
gdb bt full (11.41 KB, text/plain)
2022-06-06 21:04 UTC, postix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description postix 2022-06-06 21:02:32 UTC
SUMMARY

```
#0  0x00007f16d2a31ae8 in pthread_sigmask@GLIBC_2.2.5 () at /lib64/libc.so.6
#1  0x00007f16d29d99dd in sigprocmask () at /lib64/libc.so.6
#2  0x00007f16d3d7588b in KCrash::setCrashHandler(void (*)(int)) (handler=handler@entry=0x0) at /usr/src/debug/kcrash-5.94.0-1.1.x86_64/src/kcrash.cpp:415
#3  0x00007f16d3d77d76 in KCrash::defaultCrashHandler(int) (sig=11) at /usr/src/debug/kcrash-5.94.0-1.1.x86_64/src/kcrash.cpp:632
#4  0x00007f16d29d97c0 in <signal handler called> () at /lib64/libc.so.6
#5  0x00007f16cf43ae9a in QtWayland::wl_output::handle_done(void*, wl_output*) (data=0x556bcffe8e70, object=0x556bd00140b0) at qwayland-wayland.cpp:2247
#6  0x00007f16cf38e392 in ffi_call_unix64 () at ../src/x86/unix64.S:105
#7  0x00007f16cf38b1d2 in ffi_call_int (cif=<optimized out>, fn=<optimized out>, rvalue=<optimized out>, avalue=<optimized out>, closure=<optimized out>) at ../src/x86/ffi64.c:672
#8  0x00007f16d08bfa03 in wl_closure_invoke (closure=closure@entry=0x7f16c400b630, target=<optimized out>, target@entry=0x556bd00140b0, opcode=opcode@entry=2, data=<optimized out>, flags=1) at ../src/connection.c:1025
#9  0x00007f16d08c0143 in dispatch_event (display=0x556bcff707d0, queue=<optimized out>) at ../src/wayland-client.c:1583
#10 0x00007f16d08c0304 in dispatch_queue (queue=0x556bcff708a0, display=0x556bcff707d0) at ../src/wayland-client.c:1729
#11 wl_display_dispatch_queue_pending (display=0x556bcff707d0, queue=0x556bcff708a0) at ../src/wayland-client.c:1971
#12 0x00007f16cf413642 in QtWaylandClient::QWaylandDisplay::flushRequests() (this=<optimized out>) at qwaylanddisplay.cpp:253
#13 0x00007f16d30e6660 in QObject::event(QEvent*) (this=0x556bcff78540, e=0x7f16c4005200) at kernel/qobject.cpp:1314
#14 0x00007f16d30ba988 in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x556bcff78540, event=0x7f16c4005200) at kernel/qcoreapplication.cpp:1064
#15 0x00007f16d30bd921 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=0x0, event_type=0, data=0x556bcff69300) at kernel/qcoreapplication.cpp:1821
#16 0x00007f16d3112ec3 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x556bcff7fff0) at kernel/qeventdispatcher_glib.cpp:277
#17 0x00007f16d0ef8ea0 in g_main_dispatch (context=0x556bcff81d10) at ../glib/gmain.c:3417
#18 g_main_context_dispatch (context=0x556bcff81d10) at ../glib/gmain.c:4135
#19 0x00007f16d0ef9258 in g_main_context_iterate (context=context@entry=0x556bcff81d10, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4211
#20 0x00007f16d0ef92ec in g_main_context_iteration (context=0x556bcff81d10, may_block=1) at ../glib/gmain.c:4276
#21 0x00007f16d31125a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x556bcff7db90, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#22 0x00007f16d30b93fb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffc73648150, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#23 0x00007f16d30c1566 in QCoreApplication::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#24 0x00007f16d35a03bc in QGuiApplication::exec() () at kernel/qguiapplication.cpp:1867
#25 0x0000556bcfbf9fe5 in main(int, char**) (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/powerdevil5-5.24.5-1.2.x86_64/daemon/powerdevilapp.cpp:178
```

```
#0  0x00007f118a2d4ae8 in pthread_sigmask@GLIBC_2.2.5 () at /lib64/libc.so.6
#1  0x00007f118a27c9dd in sigprocmask () at /lib64/libc.so.6
#2  0x00007f118b50688b in KCrash::setCrashHandler(void (*)(int)) (handler=handler@entry=0x0) at /usr/src/debug/kcrash-5.94.0-1.1.x86_64/src/kcrash.cpp:415
#3  0x00007f118b508d76 in KCrash::defaultCrashHandler(int) (sig=11) at /usr/src/debug/kcrash-5.94.0-1.1.x86_64/src/kcrash.cpp:632
#4  0x00007f118a27c7c0 in <signal handler called> () at /lib64/libc.so.6
#5  0x00007f1186e99e9a in QtWayland::wl_output::handle_done(void*, wl_output*) (data=0x7f117800c240, object=0x55c511159820) at qwayland-wayland.cpp:2247
#6  0x00007f1186d44392 in ffi_call_unix64 () at ../src/x86/unix64.S:105
#7  0x00007f1186d411d2 in ffi_call_int (cif=<optimized out>, fn=<optimized out>, rvalue=<optimized out>, avalue=<optimized out>, closure=<optimized out>) at ../src/x86/ffi64.c:672
#8  0x00007f1186de7a03 in wl_closure_invoke (closure=closure@entry=0x7f117c00b170, target=<optimized out>, target@entry=0x55c511159820, opcode=opcode@entry=2, data=<optimized out>, flags=1) at ../src/connection.c:1025
#9  0x00007f1186de8143 in dispatch_event (display=0x55c510c15ff0, queue=<optimized out>) at ../src/wayland-client.c:1583
#10 0x00007f1186de8304 in dispatch_queue (queue=0x55c510c160c0, display=0x55c510c15ff0) at ../src/wayland-client.c:1729
#11 wl_display_dispatch_queue_pending (display=0x55c510c15ff0, queue=0x55c510c160c0) at ../src/wayland-client.c:1971
#12 0x00007f1186e72642 in QtWaylandClient::QWaylandDisplay::flushRequests() (this=<optimized out>) at qwaylanddisplay.cpp:253
#13 0x00007f118a98b660 in QObject::event(QEvent*) (this=0x55c510c15e30, e=0x7f117c004f50) at kernel/qobject.cpp:1314
#14 0x00007f118b75837e in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=<optimized out>, receiver=0x55c510c15e30, e=0x7f117c004f50) at kernel/qapplication.cpp:3632
#15 0x00007f118a95f988 in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x55c510c15e30, event=0x7f117c004f50) at kernel/qcoreapplication.cpp:1064
#16 0x00007f118a962921 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=0x0, event_type=0, data=0x55c510c07480) at kernel/qcoreapplication.cpp:1821
#17 0x00007f118a9b7ec3 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x55c510c64870) at kernel/qeventdispatcher_glib.cpp:277
#18 0x00007f118945eea0 in g_main_dispatch (context=0x55c510c71330) at ../glib/gmain.c:3417
#19 g_main_context_dispatch (context=0x55c510c71330) at ../glib/gmain.c:4135
#20 0x00007f118945f258 in g_main_context_iterate (context=context@entry=0x55c510c71330, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4211
#21 0x00007f118945f2ec in g_main_context_iteration (context=0x55c510c71330, may_block=1) at ../glib/gmain.c:4276
#22 0x00007f118a9b75a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x55c510c65680, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#23 0x00007f118a95e3fb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffdaa8b9680, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#24 0x00007f118a966566 in QCoreApplication::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#25 0x00007f118aee93bc in QGuiApplication::exec() () at kernel/qguiapplication.cpp:1867
#26 0x00007f118b7582f5 in QApplication::exec() () at kernel/qapplication.cpp:2824
#27 0x000055c50f3848f6 in main(int, char**) (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kded-5.94.0-1.1.x86_64/src/kded.cpp:770
```

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20220605
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.2
Kernel Version: 5.18.1-1-default (64-bit)
Graphics Platform: Wayland
Graphics Processor: AMD Radeon RX 580 Series
Comment 1 postix 2022-06-06 21:04:28 UTC
Created attachment 149514 [details]
gdb bt full
Comment 2 Nate Graham 2022-06-07 17:37:47 UTC

*** This bug has been marked as a duplicate of bug 451028 ***