Bug 454633 - Allow user to order search result
Summary: Allow user to order search result
Status: RESOLVED DUPLICATE of bug 340283
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Alexander Lohnau
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-30 23:50 UTC by xojoyac741
Modified: 2022-05-31 06:43 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Video showing how krunner juked me (3.45 MB, video/x-matroska)
2022-05-30 23:50 UTC, xojoyac741
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xojoyac741 2022-05-30 23:50:27 UTC
Created attachment 149342 [details]
Video showing how krunner juked me

SUMMARY
***
NOTE: Would be great if there was an option to sort the order of the search results. For instance, I would love to be able to sort via 1. applications, 2. settings, 3. everything else.
Just had this issue where I wanted to change a keyboard shortcut, so, naturally i open krunner and type shortcut. The first result was the shortcut settings, great right? So i press enter, but by the time my finger hit the enter key, krunner showed me some autohotkey program from discover, and that open instead :/
Other issue i have is, inside the application search plugin, I wish it would first show me the best matching NAME, then everything else. I wanted to open the tor browser, so I open krunner and type tor. Simple! but for some reason it was showing me Visual studio code first, but only after a while and only sometimes it would put it there, same issue with above! Super annoying!
I will attach a video showing the second behavior, where i go frame by frame so you can see better. 
***


STEPS TO REPRODUCE
1. 
2. 
3. 

OBSERVED RESULT


EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Kubuntu 22.04
(available in About System)
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
x11
Comment 1 Bacteria 2022-05-31 06:43:47 UTC
Please don't mention multiple problems in a single issue. Break down your problems in separate issues as this makes it really hard to track and take actions on.

I am marking this as duplicate based on the issue title. You can create new issues for the other problems you are having after checking for duplicates.

Also check out https://community.kde.org/Get_Involved/Issue_Reporting for a general guidance on how to report issues properly.

*** This bug has been marked as a duplicate of bug 340283 ***