Bug 454564 - Login screen (sddm) login and password fields have the same light background color as the text when using breeze dark and applying plasma settings in sddm settings
Summary: Login screen (sddm) login and password fields have the same light background ...
Status: RESOLVED DUPLICATE of bug 440957
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_sddm (show other bugs)
Version: 5.24.5
Platform: Neon Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-29 12:06 UTC by pzalewski7
Modified: 2022-06-01 17:52 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pzalewski7 2022-05-29 12:06:44 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***


STEPS TO REPRODUCE
1. Set global theme to breeze dark
2. Go to login screen (sddm) configuration in system settings
3. Click apply plasma settings (not the normal apply button)
4. Log out (not lock, lock works properly)

OBSERVED RESULT
The login and password input fields are white which makes the typed in text invisible (but it is typed in, you can mark it).

EXPECTED RESULT
The input fields should be dark and the text should be light.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: KDE neon 5.24
(available in About System)
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4

ADDITIONAL INFORMATION
The described behavior happens only when the apply plasma settings button is clicked in sddm settings. When doing the same thing in the settings when breeze light or breeze twilight is used, the input fields are light and the text is black (as expected). The problem is only with the dark theme. It looks like the text color is changed to white, but the input field color isn't changed to dark.
Comment 1 Nate Graham 2022-06-01 17:52:12 UTC

*** This bug has been marked as a duplicate of bug 440957 ***