Bug 454429 - Crash when raising a number to 0,5 power
Summary: Crash when raising a number to 0,5 power
Status: RESOLVED UPSTREAM
Alias: None
Product: kcalc
Classification: Applications
Component: general (show other bugs)
Version: 22.04.1
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Evan Teran
URL:
Keywords:
: 454540 454603 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-05-26 09:28 UTC by Vladislav Tatyanin
Modified: 2022-05-30 11:44 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladislav Tatyanin 2022-05-26 09:28:41 UTC
Application: kcalc (22.04.1)

Qt Version: 5.15.4
Frameworks Version: 5.94.0
Operating System: Linux 5.17.9-arch1-1 x86_64
Windowing System: X11
Distribution: "Arch Linux"
DrKonqi: 5.24.5 [KCrashBackend]

-- Information about the crash:
If you try to take the root (raise to the power of 0.5) of a non-square number (e.g. 5700), the app crashes.

The crash can be reproduced every time.

-- Backtrace:
A useful backtrace could not be generated
Comment 1 Antonio Rojas 2022-05-26 09:51:01 UTC
Same gnutls bug that breaks kmymoney (bug 453857) and the calculator runner (bug 454006). On Arch it should be fixed with 3.7.5-2
Comment 2 Antonio Rojas 2022-05-28 19:01:04 UTC
*** Bug 454540 has been marked as a duplicate of this bug. ***
Comment 3 Antonio Rojas 2022-05-30 11:44:21 UTC
*** Bug 454603 has been marked as a duplicate of this bug. ***