Bug 454193 - Hyperlinks ignore port (i.e. don't follow the :<port> part)
Summary: Hyperlinks ignore port (i.e. don't follow the :<port> part)
Status: RESOLVED DUPLICATE of bug 452978
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 22.04.0
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-22 05:22 UTC by Christian Finnberg
Modified: 2022-05-22 05:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Finnberg 2022-05-22 05:22:54 UTC
SUMMARY

Konsole opens links without the :port part

STEPS TO REPRODUCE
1. Show whatever content that shows an hyperlink with port specification (:port). For example http://127.0.0.1:8080
2. Open the link
3. 

OBSERVED RESULT
Only the domain part is opened (in the example, http://127.0.0.1) ignoring the port of the URL

EXPECTED RESULT
Open the full URL. i.e http://127.0.0.1:8080

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Manjaro 
(available in About System)
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
I think the bug was introduced in 5.24.5 and was working before that
Comment 1 Christian Finnberg 2022-05-22 05:41:34 UTC

*** This bug has been marked as a duplicate of bug 452978 ***