Bug 454047 - With tinted color scheme, title bar color doesn't update when accent color changes automatically
Summary: With tinted color scheme, title bar color doesn't update when accent color ch...
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_colors (show other bugs)
Version: 5.24.90
Platform: Neon Linux
: HI normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 455142 455537 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-05-19 15:56 UTC by Firlaev-Hans
Modified: 2022-07-05 18:11 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Firlaev-Hans 2022-05-19 15:56:26 UTC
SUMMARY
If you set your color scheme to be accent color tinted and your accent color to "From active Wallpaper", the window decoration won't update it's tinted color when the wallpaper and thus accent color changes. It will only change correctly after manually applying any setting in the System Settings Colors page.

STEPS TO REPRODUCE
1. Check "Tint all colors with accent color" in your color scheme's settings
2. Specifically DON'T check the option to apply color effects to window title bars
3. Set your accent color to "From current wallpaper"
4. Make sure to apply all these settings
5. Change the wallpaper, so that the accent color changes
6. Change the wallpaper once more, accent color changes again
7. Change anything at all in the Color settings and apply

OBSERVED RESULT
5. The window contents update their tint color but the title bars don't
6. The window contents update normally again, but the title bars now take on the color that they should have taken after step 5
7. The tint for both the title bars and the window contents is updated uniformly and correctly again

EXPECTED RESULT
The title bar colors should always be updated correctly if the accent color changes, even if it was not changed by the user from system settings but rather by changing the wallpaper

SOFTWARE/OS VERSIONS
KDE Neon Unstable
KDE Plasma Version: 5.24.80
KDE Frameworks Version: 5.95
Qt Version: 5.15.4
Comment 1 przem.formela 2022-05-20 08:17:31 UTC
I've also encountered this issue – attaching a video of errorneous behaviour (actually, it's two different behaviours) (it's on streamable cause the file is too big to attach)
https://streamable.com/5p74j3

Operating System: Arch Linux
KDE Plasma Version: 5.24.90
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4
Graphics Platform: Wayland
Comment 2 Nate Graham 2022-05-23 19:19:28 UTC
Can confirm. If you make the color change automatically a second timem the titlebar will actually change to what it *should have been* for the previous color!
Comment 3 Nate Graham 2022-07-05 18:07:47 UTC
*** Bug 455537 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2022-07-05 18:07:50 UTC
*** Bug 455142 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2022-07-05 18:09:53 UTC
Git commit 00a18a8c5aeb6c0b4e2b157dec11e4e1032d20cd by Nate Graham, on behalf of Eugene Popov.
Committed on 05/07/2022 at 18:09.
Pushed by ngraham into branch 'master'.

kcms/colors: Properly apply tinting to the window titlebar

Tint the window titlebars only when either the option to tint all colors with
accent color or the option to apply accent color to window titlebars is enabled 
or both), and in the latter case, the active window titlebars should be painted
in the accent color.
Related: bug 455395
FIXED-IN: 5.25.3

M  +16   -7    kcms/colors/colorsapplicator.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/00a18a8c5aeb6c0b4e2b157dec11e4e1032d20cd
Comment 6 Nate Graham 2022-07-05 18:10:19 UTC
Git commit 9f46232368583ef97d617782ee29f9eabd20eda8 by Nate Graham, on behalf of Eugene Popov.
Committed on 05/07/2022 at 18:10.
Pushed by ngraham into branch 'Plasma/5.25'.

kcms/colors: Properly apply tinting to the window titlebar

Tint the window titlebars only when either the option to tint all colors with
accent color or the option to apply accent color to window titlebars is enabled 
or both), and in the latter case, the active window titlebars should be painted
in the accent color.
Related: bug 455395
FIXED-IN: 5.25.3


(cherry picked from commit 00a18a8c5aeb6c0b4e2b157dec11e4e1032d20cd)

M  +16   -7    kcms/colors/colorsapplicator.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/9f46232368583ef97d617782ee29f9eabd20eda8