Bug 453980 - Selected application icon not highlighted anymore
Summary: Selected application icon not highlighted anymore
Status: RESOLVED FIXED
Alias: None
Product: kdeplasma-addons
Classification: Unclassified
Component: Application Dashboard (show other bugs)
Version: 5.25.0
Platform: Neon Packages Linux
: NOR normal
Target Milestone: ---
Assignee: ratijas
URL:
Keywords: regression
: 454811 455492 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-05-18 12:08 UTC by Dominique Lebrun
Modified: 2022-06-22 19:12 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Lebrun 2022-05-18 12:08:22 UTC
SUMMARY
In the main center panel and in the left panel ("Favorites"), it is not possible anymore to see which application icon is currently selected (either when navigating with the arrows or when hovering with the mouse). Note that it is still working as expected in the right panel (the application categories menu). 

The navigation itself seems to work fine, i.e. you can navigate with the arrows and press enter to open the application, but since no icon is highlighted it is difficult to know which application will be launched.

STEPS TO REPRODUCE
1. Open the Application Dashboard
2. Type in some search term, preferably giving multiple results
3. Navigate with the left or right arrows

OBSERVED RESULT
No icon is highlighted, giving no clue as to which application will be opened when enter is pressed.

EXPECTED RESULT
The icon of the currently selected application should be highlighted.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: KDE Neon 5.24 User Edition
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Kernel Version: 5.14.0-1036-oem (64-bit)
Graphics Platform: X11

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2022-05-18 16:15:23 UTC
Can reproduce. Probably a botched port to PlasmaExtras.Highlight. Will fix.
Comment 2 Dominique Lebrun 2022-05-24 06:51:07 UTC
On my computer, this seems has been fixed by the latest update (Plasma 5.24.5, KDE Frameworks 5.94.0).
Comment 3 Nate Graham 2022-06-06 18:04:17 UTC
*** Bug 454811 has been marked as a duplicate of this bug. ***
Comment 4 hexchain 2022-06-06 18:09:02 UTC
Seems like it happened again on the 5.25 beta.
Comment 5 Dominique Lebrun 2022-06-15 06:39:54 UTC
I confirm that the bug reappeared in Plasma 5.25.
Comment 6 Patrick Silva 2022-06-17 17:17:39 UTC
*** Bug 455492 has been marked as a duplicate of this bug. ***
Comment 7 Bug Janitor Service 2022-06-21 23:17:50 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/993
Comment 8 ratijas 2022-06-22 19:11:25 UTC
Git commit 5638ab14f8e28937cad2ae082dd4b34178d8c8d0 by ivan tkachenko.
Committed on 22/06/2022 at 12:07.
Pushed by ngraham into branch 'master'.

[applets/kicker] Fix missing highlight on Dashboard grids & list

Part of the reason was incomplete PlasmaExtras.Highlight refactoring,
other part is anchors not working for highlight instance:

    /usr/share/plasma/plasmoids/org.kde.plasma.kicker/contents/ui/DashboardRepresentation.qml:970:36:
    QML Highlight: Cannot anchor to an item that isn't a parent or sibling.

M  +4    -8    applets/kicker/package/contents/ui/DashboardRepresentation.qml
M  +1    -0    applets/kicker/package/contents/ui/ItemGridView.qml

https://invent.kde.org/plasma/plasma-desktop/commit/5638ab14f8e28937cad2ae082dd4b34178d8c8d0
Comment 9 Nate Graham 2022-06-22 19:11:54 UTC
Git commit 8cd587800990e5ebe3987834822f1c1356e8c43d by Nate Graham, on behalf of ivan tkachenko.
Committed on 22/06/2022 at 19:11.
Pushed by ngraham into branch 'Plasma/5.25'.

[applets/kicker] Fix missing highlight on Dashboard grids & list

Part of the reason was incomplete PlasmaExtras.Highlight refactoring,
other part is anchors not working for highlight instance:

    /usr/share/plasma/plasmoids/org.kde.plasma.kicker/contents/ui/DashboardRepresentation.qml:970:36:
    QML Highlight: Cannot anchor to an item that isn't a parent or sibling.


(cherry picked from commit 5638ab14f8e28937cad2ae082dd4b34178d8c8d0)

M  +4    -8    applets/kicker/package/contents/ui/DashboardRepresentation.qml
M  +1    -0    applets/kicker/package/contents/ui/ItemGridView.qml

https://invent.kde.org/plasma/plasma-desktop/commit/8cd587800990e5ebe3987834822f1c1356e8c43d