Bug 453959 - SwipeListItem actions no longer visible in NeoChat's settings page
Summary: SwipeListItem actions no longer visible in NeoChat's settings page
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kirigami
Classification: Unclassified
Component: general (show other bugs)
Version: 5.94.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: Not decided
Assignee: Marco Martin
URL:
Keywords: regression
: 454951 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-05-17 22:17 UTC by Tobias Fella
Modified: 2022-06-23 03:15 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.96


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Fella 2022-05-17 22:17:59 UTC
Since https://invent.kde.org/frameworks/kirigami/-/merge_requests/508 actions in swipelistitems are not visible

STEPS TO REPRODUCE
1. Open NeoChat -> Settings -> Accounts
2. No actions visible

SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.24
KDE Frameworks Version: 5.94 and master
Qt Version: 5.15.3/KDE
Comment 1 Nate Graham 2022-05-18 15:30:43 UTC
Can reproduce in Neochat but not the Virtual Desktops or Desktop Effects KCMs. Is it possible NeoChat is doing something odd?

Still, frameworks changes shouldn't break apps.
Comment 2 Carl Schwan 2022-06-07 11:39:06 UTC
*** Bug 454951 has been marked as a duplicate of this bug. ***
Comment 3 Bug Janitor Service 2022-06-17 14:04:01 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/kirigami/-/merge_requests/574
Comment 4 Bug Janitor Service 2022-06-17 22:20:07 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/kirigami/-/merge_requests/577
Comment 5 Jan Blackquill 2022-06-20 20:53:44 UTC
Git commit a2244ddd00b5ba495970d861cc1156d1260d1a23 by Janet Blackquill, on behalf of Jan Blackquill.
Committed on 20/06/2022 at 20:49.
Pushed by cblack into branch 'master'.

SwipeListItem: warn users when they try to override the padding

This has always resulted in a somewhat broken layout, but accomodations for
RtL make application errors much more prominent. Thus, we try and make it impossible
to override the padding, and have the component yell at end users if they try to do
so.

M  +24   -4    src/controls/templates/SwipeListItem.qml

https://invent.kde.org/frameworks/kirigami/commit/a2244ddd00b5ba495970d861cc1156d1260d1a23