Bug 453849 - Dolphin doesn't save last opened directory when shutting down computer
Summary: Dolphin doesn't save last opened directory when shutting down computer
Status: RESOLVED DUPLICATE of bug 436318
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 21.12.2
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-15 19:59 UTC by equeim
Modified: 2022-05-16 18:46 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description equeim 2022-05-15 19:59:43 UTC
SUMMARY
When computer is shut down, last opened directories

STEPS TO REPRODUCE
1. Open Dolphin. Observe that it restored last opened directories.
2. Navigate to some other directory.
3. Shut down computer without closing Dolphin.
4. Boot up computer.
4. Open Dolphin.

OBSERVED RESULT
Dolphin opens the same directory as in p. 1

EXPECTED RESULT
Dolphin opens the same directory as in p. 2

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Fedora 36
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Dolphin: 21.12.2

ADDITIONAL INFORMATION
I use Plasma with Wayland.
Comment 1 Nate Graham 2022-05-16 18:46:11 UTC
Dolphin is Wayland-native and uses Session Restore for this, but Session Restore is currently broken for wayland-native windows. See Bug 436318. It's one of the "Wayland Showstoppers" listed on https://community.kde.org/Plasma/Wayland_Showstoppers. So it'll be fixed eventually.

*** This bug has been marked as a duplicate of bug 436318 ***