Bug 453765 - Not using set cursor theme and not displaying the one selected.
Summary: Not using set cursor theme and not displaying the one selected.
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_cursortheme (show other bugs)
Version: 5.24.5
Platform: Kubuntu Linux
: VHI normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2022-05-14 02:15 UTC by Anderson
Modified: 2022-06-02 19:19 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.6


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anderson 2022-05-14 02:15:14 UTC
SUMMARY
***
Not using the cursor theme you manually set on x11, but on wayland it works. and doesnt show the ones you have installed.
***


STEPS TO REPRODUCE
1. Just install a cursor theme and change ir

OBSERVED RESULT
Defaults to default kde cursor theme

EXPECTED RESULT
Use the one you selected
Comment 1 Nate Graham 2022-05-16 17:28:51 UTC
Can confirm. Everything about this seems to be broken. :/
Comment 2 Alexander Lohnau 2022-05-17 05:22:53 UTC
Yeah, we have two major regressions in the KCM :(
Comment 3 Alexander Lohnau 2022-05-17 05:28:11 UTC
This is a regression from https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1233. I assume we have a too old version of the related X-dependencies installed.
Comment 4 Bug Janitor Service 2022-05-19 12:55:47 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1746
Comment 5 Alexander Lohnau 2022-06-02 17:43:50 UTC
Git commit ad4a9bd093e5dbea2eb66fdd5221135f74576d7c by Alexander Lohnau.
Committed on 02/06/2022 at 16:03.
Pushed by bshah into branch 'master'.

Revert "Change cursortheme installpath from ~/.icons to XdgTargetDir/icons"

This reverts commit e26425e573189eeac704d3633f3c4ce38f1cc5fe.

The KCM does not always include the install folder in the search paths.

As discussed in https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1233, a revert is
the best option for the time being.

M  +1    -1    kcms/cursortheme/xcursor/xcursor.knsrc

https://invent.kde.org/plasma/plasma-workspace/commit/ad4a9bd093e5dbea2eb66fdd5221135f74576d7c