Bug 453543 - Incorrect KCM is highlighted when I open Virtual Desktops KCM via Pager widget
Summary: Incorrect KCM is highlighted when I open Virtual Desktops KCM via Pager widget
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: sidebarview (show other bugs)
Version: master
Platform: Neon Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 443808 444177 445642 446422 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-05-08 13:46 UTC by Patrick Silva
Modified: 2022-05-12 17:59 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.6


Attachments
screen recording (1.42 MB, video/webm)
2022-05-08 13:46 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2022-05-08 13:46:00 UTC
Created attachment 148661 [details]
screen recording

STEPS TO REPRODUCE
1. please watch the attached screen recording
2. 
3. 

OBSERVED RESULT
'Virtual Desktops' is not highlighted when I open Virtual Desktops KCM via Pager widget

EXPECTED RESULT
'Virtual Desktops' should be highlighted when we open Virtual Desktops KCM via Pager widget

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.24.80
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 1 Nicolas Fella 2022-05-12 14:51:38 UTC
Git commit 40b71c085f8ceddc9b3f44fa65d8bb48dad42b4a by Nicolas Fella.
Committed on 11/05/2022 at 23:22.
Pushed by nicolasfella into branch 'master'.

Fix current index in subcategory list

We bind currentIndex to activeSubCategoryRow, but when clicking on an item this binding is broken

Manually set the current index when the backend index changes

Fixed-In: 5.24.6

M  +1    -0    sidebar/package/contents/ui/SubCategoryPage.qml

https://invent.kde.org/plasma/systemsettings/commit/40b71c085f8ceddc9b3f44fa65d8bb48dad42b4a
Comment 2 Nicolas Fella 2022-05-12 14:52:17 UTC
Git commit 684004217fd28ba45f7ce61df5b3600398ee1108 by Nicolas Fella.
Committed on 12/05/2022 at 14:51.
Pushed by nicolasfella into branch 'Plasma/5.24'.

Fix current index in subcategory list

We bind currentIndex to activeSubCategoryRow, but when clicking on an item this binding is broken

Manually set the current index when the backend index changes

Fixed-In: 5.24.6
(cherry picked from commit 40b71c085f8ceddc9b3f44fa65d8bb48dad42b4a)

M  +1    -0    sidebar/package/contents/ui/SubCategoryPage.qml

https://invent.kde.org/plasma/systemsettings/commit/684004217fd28ba45f7ce61df5b3600398ee1108
Comment 3 Nate Graham 2022-05-12 17:53:50 UTC
*** Bug 444177 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2022-05-12 17:54:31 UTC
*** Bug 446422 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2022-05-12 17:55:37 UTC
*** Bug 445642 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2022-05-12 17:57:59 UTC
*** Bug 443808 has been marked as a duplicate of this bug. ***