Bug 453449 - Kickoff does not retain size after restarting the shell
Summary: Kickoff does not retain size after restarting the shell
Status: RESOLVED DUPLICATE of bug 332512
Alias: None
Product: plasmashell
Classification: Plasma
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.24.5
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-06 03:13 UTC by PQCraft
Modified: 2022-05-06 14:47 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PQCraft 2022-05-06 03:13:25 UTC
SUMMARY
The application launcher will not save its size and editing the file every update is getting tiresome.


STEPS TO REPRODUCE
1. Resize the menu
2. Restart plasmashell or log out and log back in

OBSERVED RESULT
The launcher forgets the size I set it to.

EXPECTED RESULT
The launcher should save the size to a config file after I let go of the right mouse button (when I'm done resizing).

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch/5.24.5
(available in About System)
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Kernel: 5.17.5
Graphics Platform: X11
Comment 1 Noah Davis 2022-05-06 07:07:59 UTC
I agree it would be nice to let users resize the menu and keep the size across restarts. Unlike normal app windows, we don't currently have a good way to do this for plasma widget popups. The resizing is basically a hidden feature and as far as I can tell, it only works on X11. Marking this as confirmed because it would be nice to have this.
Comment 2 Nate Graham 2022-05-06 14:47:38 UTC
Will be fixed with the fix for Bug 332512. That's being actively worked on for Plasma 5.26!

*** This bug has been marked as a duplicate of bug 332512 ***