Bug 453448 - Link recognition ignores port
Summary: Link recognition ignores port
Status: RESOLVED DUPLICATE of bug 452978
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 22.04.0
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-06 02:28 UTC by suienzan
Modified: 2022-05-06 12:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description suienzan 2022-05-06 02:28:18 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***


STEPS TO REPRODUCE
1. `echo http://localhost:8080`
2. holding `ctrl` and click on the output `http://localhost:8080` or select it and right click then choose `open link`.

OBSERVED RESULT
Open link `http://localhost`

EXPECTED RESULT
Open link `http://localhost:8080`

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch linux
(available in About System)
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
Comment 1 Lorenzo Micci 2022-05-06 06:47:27 UTC
(In reply to suienzan from comment #0)
> SUMMARY
> ***
> NOTE: If you are reporting a crash, please try to attach a backtrace with
> debug symbols.
> See
> https://community.kde.org/Guidelines_and_HOWTOs/Debugging/
> How_to_create_useful_crash_reports
> ***
> 
> 
> STEPS TO REPRODUCE
> 1. `echo http://localhost:8080`
> 2. holding `ctrl` and click on the output `http://localhost:8080` or select
> it and right click then choose `open link`.
> 
> OBSERVED RESULT
> Open link `http://localhost`
> 
> EXPECTED RESULT
> Open link `http://localhost:8080`
> 
> SOFTWARE/OS VERSIONS
> Linux/KDE Plasma: Arch linux
> (available in About System)
> KDE Plasma Version: 5.24.5
> KDE Frameworks Version: 5.93.0
> Qt Version: 5.15.3
> 
> ADDITIONAL INFORMATION

Hi, is attributable to this bug https://bugs.kde.org/show_bug.cgi?id=452978
Comment 2 Ahmad Samir 2022-05-06 12:48:51 UTC
Indeed a duplicate.

*** This bug has been marked as a duplicate of bug 452978 ***