Bug 453436 - switching inputs on monitor causes plasmashell to crash.
Summary: switching inputs on monitor causes plasmashell to crash.
Status: RESOLVED DUPLICATE of bug 451267
Alias: None
Product: plasmashell
Classification: Plasma
Component: Panel (show other bugs)
Version: 5.24.5
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-05 19:07 UTC by antonio
Modified: 2022-05-09 15:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
crash log backtrace - inputs for nate (8.93 KB, text/vnd.kde.kcrash-report)
2022-05-06 09:51 UTC, antonio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description antonio 2022-05-05 19:07:27 UTC
SUMMARY

Sorry if this is a repost, i have a crash when on newest kde at time on arch, where i switch inputs in my monitor inbuilt menu from displayport (pc) to hdmi 1 (my television equipment)

i have a lg 27inch 4k screen, amd 6600xt gpu. virgin media tv 360 box is the hdmi.

it makes the bottom panel disappear when i go back to use computer after watching the television.

STEPS TO REPRODUCE
1. switch on computer, use it as normal, nothing wrong.
2. switch input whilst computer is still powered on, to hdmi - for tv box.
3. switch back to displayport and the panel is missing from kde desktop, bug filing pop ups. (says there is not enough info to report it automatically)

OBSERVED RESULT

after switching inputs on monitor it crashes and disappears the panel.

EXPECTED RESULT

panel still being present and being able to use the computer as intended. 

SOFTWARE/OS VERSIONS
Windows:  wut?
macOS: nah.
Linux/KDE Plasma: 5.17.5-arch 1 (was it asking for kernel?) arch rolling release.
(available in About System)
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2022-05-05 22:14:01 UTC
If something crashed, we need a backtrace of it so we can figure out what's going on. See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports

Can you please attach one? Thanks!
Comment 2 antonio 2022-05-06 09:51:19 UTC
Created attachment 148602 [details]
crash log backtrace - inputs for nate

sorry for not providing it initially, hope this comes in handy, I can recreate the bug if you need another log, let me know, more than happy to help.
Comment 3 Nate Graham 2022-05-09 15:32:58 UTC

*** This bug has been marked as a duplicate of bug 451267 ***