Bug 453365 - Breeze cursor script generates png files that are too small
Summary: Breeze cursor script generates png files that are too small
Status: RESOLVED FIXED
Alias: None
Product: Breeze
Classification: Unclassified
Component: general (show other bugs)
Version: master
Platform: Debian stable Linux
: NOR minor
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-03 23:18 UTC by Chris
Modified: 2022-05-05 14:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2022-05-03 23:18:23 UTC
SUMMARY
***
The cursor build scripts (breeze/cursors/Breeze/build.sh and breeze/cursors/Breeze_Snow/build.sh) generate png files that are a few pixels smaller than the ones tracked in the repo.  The cursors built from the smaller png files do not line up correctly with the hotspots defined in the cursor configuration files.
***

STEPS TO REPRODUCE
1. Delete the build directory in a cursor folder.
2. On a system with Inkscape >= 0.92, run build.sh to generate new cursors.
3. Check dimensions of the png files.

OBSERVED RESULT

The pngs in build/x1 are 30 by 30 pixels.
The pngs in build/x1_5 are 45 by 45 pixels.
The pngs in build/x2 are 60 by 60 pixels.

EXPECTED RESULT

The pngs should be 32 by 32, 48 by 48, and 64 by 64 pixels.

SOFTWARE/OS VERSIONS

Latest master commit of Breeze repo.
Inkscape >= 0.92

ADDITIONAL INFORMATION

The build script controls the png size with the -d (export-dpi) flag, Inkscape switched from 90dpi as a default to 96dpi in version 0.92 (https://inkscape.org/release/inkscape-0.92/).  A couple LTS distros, like Ubuntu 14.04 and 16.04, still use Inkscape versions prior to 0.92.
Comment 1 Chris 2022-05-03 23:46:52 UTC
I submitted a pull request (https://invent.kde.org/plasma/breeze/-/merge_requests/218/) to correct this.
Comment 2 Jan Blackquill 2022-05-04 00:17:08 UTC
Git commit a907a4aa177d8c102b0c1c1fcfb28f4242fb1c1e by Jan Blackquill, on behalf of Chris Chris.
Committed on 04/05/2022 at 00:17.
Pushed by cblack into branch 'master'.

Fix cursor build script generating pngs that are too small

The cursor build scripts generate pngs that are too small when using Inkscape 0.92 or later due to Inkscape changing its default dpi from 90 to 96. Changed script to use width and height flags as they produce png files with correct dimensions on all Inkscape versions.

M  +9    -9    cursors/Breeze/build.sh
M  +9    -9    cursors/Breeze_Snow/build.sh

https://invent.kde.org/plasma/breeze/commit/a907a4aa177d8c102b0c1c1fcfb28f4242fb1c1e