Bug 453364 - url with comma is incorrectly highlighted and opened (like cut) in web browser (after using Ctrl+left click)
Summary: url with comma is incorrectly highlighted and opened (like cut) in web browse...
Status: RESOLVED DUPLICATE of bug 452978
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 22.04.0
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-05-03 23:10 UTC by Piotr Mierzwinski
Modified: 2022-05-04 16:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Mierzwinski 2022-05-03 23:10:47 UTC
SUMMARY
Below please find example of url with coma which was cut in moment of opening it in web browser (Firefox). Of course in result I got "Page not found". Of course it was also incorrectly highlighted.
https://www.filmweb.pl/film/C%27mon+C%27mon-2021-850352/discussion/Wszystko%2C+czego+powinni%C5%9Bmy+si%C4%99+nauczy%C4%87,3263273

STEPS TO REPRODUCE
1. In Settings please check highlighting the urls
2.  Put url with coma in text file
3. Open it / view
4. move mouse to be over given url and alternatively click into it holding Ctrl key

OBSERVED RESULT
url is highlighted till coma (not included)

EXPECTED RESULT
highlighting should include also coma and part after it

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.25.5
KDE Frameworks Version: 5.93
Qt Version: 5.15.3

ADDITIONAL INFORMATION
Comment 1 Ahmad Samir 2022-05-04 12:25:21 UTC
Should be fixed by https://invent.kde.org/utilities/konsole/-/merge_requests/646

*** This bug has been marked as a duplicate of bug 452978 ***
Comment 2 Ahmad Samir 2022-05-04 16:37:15 UTC
(The fix hasn't been committed to master yet).

*** This bug has been marked as a duplicate of bug 452978 ***