Bug 453240 - kmail not downloading emails immediately on launch
Summary: kmail not downloading emails immediately on launch
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.20.0
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-30 18:26 UTC by BingMyBong
Modified: 2022-06-12 04:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BingMyBong 2022-04-30 18:26:19 UTC
STEPS TO REPRODUCE
1.  launch kmail
2. 
3. 

OBSERVED RESULT
Kmail loads but does not start downloading emails until the "check emails" delay has timed out

EXPECTED RESULT
Kmail to start downloading emails immediately on launch

SOFTWARE/OS VERSIONS
opensuse:tumbleweed:20220426
Qt: 5.15.2 KDE Frameworks: 5.93.0 - KDE Plasma:  5.24.4 - kwin 5.24.4
kmail2 5.20.0 (22.04.0) - akonadiserver 5.20.0 (22.04.0) - Kernel:  5.17.4-1-default 
ADDITIONAL INFORMATION
Comment 1 Colin J Thomson 2022-05-05 17:08:23 UTC
I am also seeing this with all my Imap accounts, Gmail being one of them > kmail-22.04.0-1.fc36

Operating System: Fedora Linux 36
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Kernel Version: 5.17.5-300.fc36.x86_64 (64-bit)
Comment 2 Christophe Giboudeaux 2022-05-13 08:08:17 UTC
In KMail settings, Accounts / Receiving there's a "Retrieval Options" menu for each account, Is the "Check mail on startup" box checked?
Comment 3 BingMyBong 2022-05-13 10:18:21 UTC
(In reply to Christophe Giboudeaux from comment #2)
> In KMail settings, Accounts / Receiving there's a "Retrieval Options" menu
> for each account, Is the "Check mail on startup" box checked?

Yes, its always been ticked
Comment 4 Bug Janitor Service 2022-05-28 04:35:51 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Bug Janitor Service 2022-06-12 04:35:34 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!