Bug 453236 - When uninstalling an application, ask whether to delete the data
Summary: When uninstalling an application, ask whether to delete the data
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: Flatpak Backend (show other bugs)
Version: 5.24.4
Platform: Other Linux
: NOR wishlist
Target Milestone: ---
Assignee: Dan Leinir Turthra Jensen
URL:
Keywords:
: 434181 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-04-30 17:39 UTC by Emanuele
Modified: 2022-05-08 17:06 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emanuele 2022-04-30 17:39:40 UTC
It is not a bug, but a request for functionality.
Flatpak has a flag to uninstallation to delete application data:
flatpak uninstall  App --delete-data

The advantage for the user is the saving of space on non usable data.
On Gnome Software they have a Mackup:  https://gitlab.gnome.org/GNOME/gnome-software/-/issues/257
Comment 1 Aleix Pol 2022-05-06 22:26:59 UTC
Git commit d85fedadfad5e598e26fe5df13208d93249de0e5 by Aleix Pol.
Committed on 06/05/2022 at 22:25.
Pushed by apol into branch 'master'.

flatpak: Show a warning when uninstalled apps still have data present

Uninstalling from flatpak will only uninstall the app but will leave the
user data in the file system. This adds the option to remove it.

M  +20   -1    libdiscover/backends/FlatpakBackend/FlatpakResource.cpp
M  +7    -1    libdiscover/backends/FlatpakBackend/FlatpakResource.h
A  +29   -0    libdiscover/backends/FlatpakBackend/qml/FlatpakRemoveData.qml     [License: GPL(3+eV) GPL(v3.0) GPL(v2.0)]
M  +1    -0    libdiscover/backends/FlatpakBackend/resources.qrc

https://invent.kde.org/plasma/discover/commit/d85fedadfad5e598e26fe5df13208d93249de0e5
Comment 2 Emanuele 2022-05-07 11:33:42 UTC
Thanks for the work you do
Comment 3 soredake 2022-05-08 17:06:34 UTC
*** Bug 434181 has been marked as a duplicate of this bug. ***