Bug 452700 - Unusably tiny window size after 'restore' is used
Summary: Unusably tiny window size after 'restore' is used
Status: RESOLVED DOWNSTREAM
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.24.4
Platform: Neon Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL: https://bugs.documentfoundation.org/s...
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-17 13:23 UTC by BOF
Modified: 2022-04-25 15:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Tiny LibreOffice window in the top right. (1.38 MB, image/png)
2022-04-17 13:23 UTC, BOF
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BOF 2022-04-17 13:23:27 UTC
Created attachment 148204 [details]
Tiny LibreOffice window in the top right.

SUMMARY
I clicked on the 'restore' button of the window. The window was resized to a tiny window. The only thing that was visible was the close button. Not even the button to enlarge the window again was visible.


STEPS TO REPRODUCE
I did that in a Window of LibreOffice. I have no idea how you could reproduce the bug.

OBSERVED RESULT
The window is resized to a tiny part of the screen.

EXPECTED RESULT
Keep a minimum size so that at least the 'Maximise' and 'Close' buttons are visible. Maybe even a bit larger to show some content as well.

SOFTWARE/OS VERSIONS
Operating System: KDE neon 5.24
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Kernel Version: 5.13.0-39-generic (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 4800H with Radeon Graphics
Memory: 30.8 GiB of RAM
Graphics Processor: AMD RENOIR

ADDITIONAL INFORMATION
I have no idea if this section is the right place to post this. If not, feel free to move it.
I will also post this bug on the LibreOffice bugtracker since I have no idea if the application has to set a minimum size or if the window manager has to do that (or may set a default by itself if nothing is entered)
Comment 1 BOF 2022-04-17 13:33:39 UTC
Entry on the LibreOffice bug tracker: https://bugs.documentfoundation.org/show_bug.cgi?id=148637
Comment 2 Nate Graham 2022-04-18 16:33:37 UTC
Does the same thing happen in the Plasma Wayland session, or is this bug X11-only?q
Comment 3 BOF 2022-04-21 08:51:05 UTC
(In reply to Nate Graham from comment #2)
> Does the same thing happen in the Plasma Wayland session, or is this bug
> X11-only?q

I tested the same steps as described on Wayland, but I could not reproduce it.
As said: I have no idea why this happened in the first place (be it X11 or Wayland) so I have no idea how to reproduce this. My best guess is that there were no set defaults for a window size so it used the smallest possible. Once a window size is set (eg. by resizing the window by dragging the corners) this problem would not happen again. My guess here would be that it will never happen on x11 or Wayland again since the window was resized.

What I could test is if I can reproduce the problem on a live system with a freshly installed LibreOffice.
Comment 4 Nate Graham 2022-04-21 14:58:12 UTC
Thanks. And does this only affect LibreOffice, or any other windows too?
Comment 5 BOF 2022-04-21 15:24:00 UTC
(In reply to Nate Graham from comment #4)
> Thanks. And does this only affect LibreOffice, or any other windows too?

I only ever noticed this on LibreOffice. However, I never tested any other application if they do anything like it.
I'll try to make some time for testing on the weekend and see if a live KDE neon + fresh LibreOffice and if other applications show the same behaviour.
Comment 6 BOF 2022-04-25 08:28:33 UTC
(In reply to BOF from comment #5)
> I only ever noticed this on LibreOffice. However, I never tested any other
> application if they do anything like it.

I have checked all my other applications I have on my system and I did not see this behaviour.

> neon + fresh LibreOffice and if other applications show the same behaviour.

I tested this bug with a live KDE neon (neon-user-20220414-0946) with a fresh install of LibreOffice as flatpack (just like it is setup on my system). I could not observe this bug again. To be fair: I have no idea why this bug came uo in the first place.
I was only able to test this on X11 since I was not able to switch to Wayland because of the auto-login (The only way I know is to sign off and sign back in with Wayland)
Comment 7 Nate Graham 2022-04-25 15:20:12 UTC
It really sounds like a LibreOffice bug. Let's track it at https://bugs.documentfoundation.org/show_bug.cgi?id=148637.