Bug 452607 - After upgrade to KDE Framework 5.93 some plasmoids open in wrong size
Summary: After upgrade to KDE Framework 5.93 some plasmoids open in wrong size
Status: RESOLVED DUPLICATE of bug 452512
Alias: None
Product: frameworks-plasma
Classification: Frameworks and Libraries
Component: components (show other bugs)
Version: 5.93.0
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-14 11:29 UTC by Peter Ries
Modified: 2022-04-17 18:21 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
plasmoid with wrong opened window size (18.93 KB, image/png)
2022-04-14 11:29 UTC, Peter Ries
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Ries 2022-04-14 11:29:08 UTC
Created attachment 148152 [details]
plasmoid with wrong opened window size

SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***


STEPS TO REPRODUCE
1. have a plasma desktop with KDE FW 5.92
2. add sticky notes plasmoid to taskbar
3. upgrade system to have KDE FW 5.93
4. reboot

OBSERVED RESULT
click on Stick Notes icon in taskbar "opens" plasmoid in a miniminimal window (s. attached screenshot)
Event Calendar e. g. shows a similar behaviour. Opening Event Calendar's settings dialog and clicking save results in a temporary cure of this behaviour. Plasmoids work normally until next reboot.

EXPECTED RESULT
Plasmoid Window shoud open in correct size

SOFTWARE/OS VERSIONS
Operating System: EndeavourOS
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Kernel Version: 5.17.2-arch3-1 (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 PRO 4750U with Radeon Graphics
Memory: 30.6 GiB of RAM
Graphics Processor: AMD RENOIR
ADDITIONAL INFORMATION
Comment 1 Cristiano Guadagnino 2022-04-14 11:51:38 UTC
Happens here too:
Operating System: openSUSE Tumbleweed 20220412
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.2
Kernel Version: 5.17.1-1-default (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 3600 6-Core Processor
Memory: 15,5 GiB of RAM
Graphics Processor: AMD Radeon RX 550 / 550 Series
Comment 2 t0fun3rd@gmail.com 2022-04-14 14:27:45 UTC
Happens on Arch too
Comment 3 David Edmundson 2022-04-14 14:28:38 UTC
*** Bug 452602 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2022-04-14 14:32:51 UTC

*** This bug has been marked as a duplicate of bug 452512 ***
Comment 5 Peter Ries 2022-04-17 18:21:27 UTC
fixed today in arch / endeavour with 

extra/plasma-framework        5.93.0-1     -->      5.93.0-2