Bug 452555 - PlasmaComponents.Highlight (e.g. in LegacyKickoff) invisible since update
Summary: PlasmaComponents.Highlight (e.g. in LegacyKickoff) invisible since update
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Unclassified
Component: components (show other bugs)
Version: 5.93.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 452647 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-04-12 17:34 UTC by Christian (Fuchs)
Modified: 2022-04-18 16:00 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.94


Attachments
screenshot of issue, left correct, right wrong, both highlight the same item (konsole) (173.66 KB, image/png)
2022-04-12 17:34 UTC, Christian (Fuchs)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian (Fuchs) 2022-04-12 17:34:25 UTC
Created attachment 148122 [details]
screenshot of issue, left correct, right wrong, both highlight the same item (konsole)

Filing as per discussion in the VDG group: 

since upgrading to KF 5.93  (could have been 92, maybe I skipped a version) the 
PlasmaComponents.Highlight  used by LegacyKickoff (https://store.kde.org/p/1468103) is invisible. 

It is marked as deprecated but still available in the api docs, so this might also hit other products.

STEPS TO REPRODUCE
1. Install https://store.kde.org/p/1468103
2. Open
3. Hover a list item

OBSERVED RESULT
Highlight overlay not visible (see screenshot)

EXPECTED RESULT
Highlight overlay visible

Betriebssystem: Fedora Linux 36
KDE-Plasma-Version: 5.24.4
KDE-Frameworks-Version: 5.93.0
Qt-Version: 5.15.3
Kernel-Version: 5.17.2-300.fc36.x86_64 (64-bit)
Grafik-Plattform: X11
Comment 1 Aleix Pol 2022-04-14 14:53:44 UTC
Git commit 734b956c27bd76df7fed6979beb27c2f30cbd3bf by Aleix Pol.
Committed on 14/04/2022 at 00:35.
Pushed by ngraham into branch 'master'.

Keep PlasmaComponents.Highlight on its former behaviour

Otherwise some applets like Kickoff Legacy don't get a highlight

M  +2    -0    src/declarativeimports/plasmacomponents/qml/Highlight.qml

https://invent.kde.org/frameworks/plasma-framework/commit/734b956c27bd76df7fed6979beb27c2f30cbd3bf
Comment 2 Nate Graham 2022-04-18 16:00:28 UTC
*** Bug 452647 has been marked as a duplicate of this bug. ***