Bug 452405 - Random wallpaper glitch after unlocking the screen on a dual monitor setup
Summary: Random wallpaper glitch after unlocking the screen on a dual monitor setup
Status: RESOLVED DUPLICATE of bug 447705
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: 5.24.4
Platform: openSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2022-04-08 14:23 UTC by postix
Modified: 2022-04-08 23:05 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot (910.17 KB, image/png)
2022-04-08 14:23 UTC, postix
Details
KWin Support Information (6.53 KB, text/plain)
2022-04-08 14:24 UTC, postix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description postix 2022-04-08 14:23:55 UTC
Created attachment 148045 [details]
Screenshot

SUMMARY

Two screens: FullHD@100% (HDMI) and 4k@200% (DP). After unlocking, the wallpaper of the HDMI screen looks like in the screenshot: The actual wallpaper is re-scaled to a 1/4 of its original size and displayed in the upper left corner and the rest of the screen is filled with stripes originating from the wallpaper and a uniform colored area.

I've been experiencing this every now and then since 5.24.0.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20220405
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.2
Kernel Version: 5.17.1-1-default (64-bit)
Graphics Platform: Wayland
Graphics Processor: AMD Radeon RX 580 Series
Comment 1 postix 2022-04-08 14:24:14 UTC
Created attachment 148046 [details]
KWin Support Information
Comment 2 Nate Graham 2022-04-08 15:26:49 UTC
I have seen this with exactly that setup: a 200% scale 4K internal laptop screen connected to a 100% scale 1080p external screen via HDMI
Comment 3 David Edmundson 2022-04-08 15:36:02 UTC
Please confirm that https://invent.kde.org/plasma/kwin/-/merge_requests/2188 fixes it.
Comment 4 postix 2022-04-08 15:44:43 UTC
(In reply to David Edmundson from comment #3)
> Please confirm that https://invent.kde.org/plasma/kwin/-/merge_requests/2188 fixes it.

Nate, could you please test this MR? I currently don't have a suitable KWin development setup. Thanks. :)
Comment 5 Nate Graham 2022-04-08 15:45:59 UTC
Sure, I'll do that momentarily.
Comment 6 Nate Graham 2022-04-08 16:25:07 UTC
Yep, that seems to fix it!
Comment 7 David Edmundson 2022-04-08 23:05:16 UTC

*** This bug has been marked as a duplicate of bug 447705 ***