Bug 452347 - PlasmoidHeader sharpens top corners of themes that have round corners in notifications
Summary: PlasmoidHeader sharpens top corners of themes that have round corners in noti...
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Frameworks and Libraries
Component: components (show other bugs)
Version: 5.92.0
Platform: Archlinux Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: veggero
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-06 19:56 UTC by doncbugs
Modified: 2022-11-24 15:55 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.26.4


Attachments
Sharp corners on top, round on bottom (6.07 KB, image/png)
2022-04-06 19:56 UTC, doncbugs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description doncbugs 2022-04-06 19:56:27 UTC
Created attachment 148007 [details]
Sharp corners on top, round on bottom

SUMMARY

When using a plasmoidheading.svg in a theme, if the corners are rounded, they are not present in the notification. They are drawn on dialogs, though. It seems that the -top elements are not included. I thought it was because there was not enough room, but the assets themselves are quite small, only being 8x8 in my case.

I tried looking at other themes for solutions and it appears everyone either removes the top header altogether or makes it a faint or similar color.


STEPS TO REPRODUCE
1. Choose Breeze Dark
2. Ideally go to a white background for best clarity
3. run notify-send test

OBSERVED RESULT
Top corners are sharp rectangles, bottom corners are rounded like the rest of the theme.

EXPECTED RESULT
The appropriate top parts of plasmoidheading are drawn instead of sharply sticking out past the edges of the notification.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 5.17.1-arch1-1 (64-bit)
Graphics Platform: X11
Comment 1 Nate Graham 2022-04-07 15:27:18 UTC
Confirmed. Niccolò, is there anything we can do here?
Comment 2 Bug Janitor Service 2022-11-24 15:05:19 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/2357
Comment 3 Nate Graham 2022-11-24 15:53:57 UTC
Git commit 537943a5599bb6539a3f140d598f2ce4b41a7e3d by Nate Graham, on behalf of Niccolò Venerandi.
Committed on 24/11/2022 at 15:53.
Pushed by ngraham into branch 'master'.

applets/notifications: remove negative inset from PlasmoidHeading

there's no margin in notifications, so this is unnecessary. With this fix
applied, notifications should now have rounded corners on all four sides.
FIXED-IN: 5.26.4

M  +1    -0    applets/notifications/package/contents/ui/NotificationItem.qml

https://invent.kde.org/plasma/plasma-workspace/commit/537943a5599bb6539a3f140d598f2ce4b41a7e3d
Comment 4 Nate Graham 2022-11-24 15:55:01 UTC
Git commit 70ba188d62fa9864318dabe2fc6b55ab182268bf by Nate Graham, on behalf of Niccolò Venerandi.
Committed on 24/11/2022 at 15:54.
Pushed by ngraham into branch 'Plasma/5.26'.

Remove negative inset of plasmoid heading in notifications since there's no margin in those


(cherry picked from commit e56fc41d25e26002ff10d5d975cc97cf106831a8)

M  +1    -0    applets/notifications/package/contents/ui/NotificationItem.qml

https://invent.kde.org/plasma/plasma-workspace/commit/70ba188d62fa9864318dabe2fc6b55ab182268bf