Bug 452308 - Wallpaper thumbnails in "Configure Desktop and Wallpaper" use the aspect ratio of the screen that the window is located on, not the screen it will change the wallpaper for
Summary: Wallpaper thumbnails in "Configure Desktop and Wallpaper" use the aspect rati...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Image Wallpaper (show other bugs)
Version: 5.24.4
Platform: Neon Packages Linux
: NOR minor
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-05 21:06 UTC by Philipp Verpoort
Modified: 2022-05-30 00:13 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.6


Attachments
Screenshot #1 (2.50 MB, image/png)
2022-04-05 21:06 UTC, Philipp Verpoort
Details
Screenshot #2 (2.48 MB, image/png)
2022-04-05 21:07 UTC, Philipp Verpoort
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Verpoort 2022-04-05 21:06:52 UTC
Created attachment 147988 [details]
Screenshot #1

Apologies in advance in case I filed this bug in the wrong place, in which case I appreciate your help in correcting this.

SUMMARY
In KDE Plasma, the wallpaper of a screen can be modified by right-clicking on the empty desktop, selecting "Configure Desktop and Wallpaper" from the context menu, and then choosing a new wallpaper to use as a background image for that particular screen.

Apparently, a new feature (as of 5.24.4?) seems to be that the layout of the thumbnails of all available wallpaper images is now determined by the size of the respective screen. The size of the screen is however not determined by the properties of the screen whose wallpaper is being edited but rather by the properties of the screen that the "Configure Desktop and Wallpaper" is placed on. This does not affect which screen gets edited though.

Attached are two screenshots from the same window, where in the second screenshot, the size/layout of the thumbnails updated in that moment where the window was dragged across the border between the two screens such that the centre of the window is now on the new screen.

Essentially, this bug occurs because the ratio/properties of the screen taken to display the thumbnails was not obtianed from the screen that is being edited but rather from the screen of the window.


STEPS TO REPRODUCE
1. Have at least two monitors of dissimilar aspect ratios/resolutions.
2. Right-click on monitor 1. Select "Configure Desktop and Wallpaper"
3. Now drag the window over to monitor 2.

OBSERVED RESULT
After 2: Observe how the thumbnails have the correct aspect ratio corresponding to the screen whose wallpaper you are trying to edit (provided the window opens on monitor 1).
After 3: Observe how the thumbnail aspect ratio changes to adopt the resolution of monitor 2.


EXPECTED RESULT
The aspect ratio of the thumbnails does not change.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: KDE Neon 5.24
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Comment 1 Philipp Verpoort 2022-04-05 21:07:21 UTC
Created attachment 147989 [details]
Screenshot #2
Comment 2 Nate Graham 2022-04-06 18:19:29 UTC
Hah, can confirm.
Comment 3 Bug Janitor Service 2022-05-28 02:48:36 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1775
Comment 4 Fushan Wen 2022-05-29 16:16:21 UTC
Git commit 19084358c7c4e29fc7a99183ca0af1b947664a72 by Fushan Wen.
Committed on 29/05/2022 at 16:06.
Pushed by fusionfuture into branch 'master'.

wallpapers/image: use the aspect ratio of the screen it will change the wallpaper for

Th aspect ratio of thumbnails should follow the Plasmoid size, not the screen size.
FIXED-IN: 5.25

M  +21   -2    wallpapers/image/imagepackage/contents/ui/ThumbnailsComponent.qml

https://invent.kde.org/plasma/plasma-workspace/commit/19084358c7c4e29fc7a99183ca0af1b947664a72
Comment 5 Fushan Wen 2022-05-30 00:03:00 UTC
Git commit 05df0bbe79a57f50039e0cf91c3e745f6baaad77 by Fushan Wen.
Committed on 30/05/2022 at 00:00.
Pushed by fusionfuture into branch 'Plasma/5.25'.

wallpapers/image: use the aspect ratio of the screen it will change the wallpaper for

Th aspect ratio of thumbnails should follow the Plasmoid size, not the screen size.
FIXED-IN: 5.25

(cherry picked from 19084358c7c4e29fc7a99183ca0af1b947664a72)

M  +21   -2    wallpapers/image/imagepackage/contents/ui/ThumbnailsComponent.qml

https://invent.kde.org/plasma/plasma-workspace/commit/05df0bbe79a57f50039e0cf91c3e745f6baaad77
Comment 6 Fushan Wen 2022-05-30 00:13:51 UTC
Git commit 0b23a298089dc30ce97c8489481d79d93b70877e by Fushan Wen.
Committed on 30/05/2022 at 00:09.
Pushed by fusionfuture into branch 'Plasma/5.24'.

wallpapers/image: use the aspect ratio of the screen it will change the wallpaper for

Th aspect ratio of thumbnails should follow the Plasmoid size, not the screen size.
FIXED-IN: 5.24.6

(cherry picked from 19084358c7c4e29fc7a99183ca0af1b947664a72)

M  +20   -2    wallpapers/image/imagepackage/contents/ui/config.qml

https://invent.kde.org/plasma/plasma-workspace/commit/0b23a298089dc30ce97c8489481d79d93b70877e