Bug 452170 - An Animated Transparency/Filter Mask can not be fully manipulated on the Timeline.
Summary: An Animated Transparency/Filter Mask can not be fully manipulated on the Time...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Animation (show other bugs)
Version: nightly build (please specify the git hash!)
Platform: Debian stable Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-02 10:42 UTC by Ahab Greybeard
Modified: 2022-04-06 03:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Example file for testing with (1.52 MB, application/x-krita)
2022-04-02 10:42 UTC, Ahab Greybeard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ahab Greybeard 2022-04-02 10:42:02 UTC
SUMMARY
This is the case for all versions and is reported for the Apr 01 5.1.0-prealpha (git a005597297) appimage on Debian 10.

A testing file, 'Manipulate Anim Trans-Filter Masks', is attached for ease and convenience of testing.

This has a static painted rectangle which has a simple animated transparency mask on it.
It also has an animated Hue shift Filter Mask on it with the same painted content.
There is also an animated paint layer that has content similar to the animated masks, for comparison.

Note: Any testing will be subject to this bug:
https://bugs.kde.org/show_bug.cgi?id=452153
so that if you close the file then open it again, there will probably be a crash.

STEPS TO REPRODUCE
1. Open the attached file, enable the Trans-1 mask and observe its contents on the Timeline.
2. Select a frame of Trans-1 and do Copy Keyframes.
3. Select frame-30 (or somewhere) of Trans-1 and try to Paste Keyframes.
4. Select frame-30 of Paint-2 and try to Paste Keyframes.
5. Try the preceding steps but using the Filter-1 mask layer and frames.
6. Try Mirroring and select-dragging frames of the masks.

OBSERVED RESULT
2. It can be copied
3. It can't be pasted, the action is greyed out.
4. It can be pasted onto the paint layer frame.
5. You can't paste onto a filter mask keyframe.
6. That can be done.

EXPECTED RESULT
An animated transparency mask and an animated filter mask should be able to be manipulated on the Timeline in the same way that an animated paint layer can be manipulated.

SOFTWARE/OS VERSIONS
Krita
 Version: 5.1.0-prealpha (git a005597)
 Languages: en_GB, en, en, en_GB, en
 Hidpi: false

Qt
  Version (compiled): 5.12.12
  Version (loaded): 5.12.12

OS Information
  Build ABI: x86_64-little_endian-lp64
  Build CPU: x86_64
  CPU: x86_64
  Kernel Type: linux
  Kernel Version: 4.19.0-20-amd64
  Pretty Productname: Debian GNU/Linux 10 (buster)
  Product Type: debian
  Product Version: 10
  Desktop: MATE
Comment 1 Ahab Greybeard 2022-04-02 10:42:43 UTC
Created attachment 147890 [details]
Example file for testing with
Comment 2 Emmet O'Neill 2022-04-06 03:21:10 UTC
Git commit 209da314203c34d835954cf3890c3bd400913221 by Emmet O'Neill.
Committed on 06/04/2022 at 03:18.
Pushed by emmetoneill into branch 'master'.

Animation: Adjusted various GUI activation flags.

Some features were not properly accessible due to inappropriate action
activation flags. That's fixed now, and I've also gone ahead and double-checked
all of the animation-related action activate flags.

M  +59   -54   krita/krita.action

https://invent.kde.org/graphics/krita/commit/209da314203c34d835954cf3890c3bd400913221
Comment 3 Emmet O'Neill 2022-04-06 03:22:06 UTC
Git commit 02aed2aba9c6128fb2b88cd23affe0a642dbf7b8 by Emmet O'Neill.
Committed on 06/04/2022 at 03:22.
Pushed by emmetoneill into branch 'krita/5.0'.

Animation: Adjusted various GUI activation flags.

Some features were not properly accessible due to inappropriate action
activation flags. That's fixed now, and I've also gone ahead and double-checked
all of the animation-related action activate flags.


(cherry picked from commit 209da314203c34d835954cf3890c3bd400913221)

M  +59   -54   krita/krita.action

https://invent.kde.org/graphics/krita/commit/02aed2aba9c6128fb2b88cd23affe0a642dbf7b8
Comment 4 Emmet O'Neill 2022-04-06 03:24:53 UTC
Ok, I believe the problem here was caused by the use of inappropriate action activation flags and should now be fixed in master and 5.0 branches.

Thanks as always for the excellent bug report and test file, Ahab Greybeard. :)