Bug 451817 - Render fails instantly 21.12.3 on Linux Mint kdenlive-21.12.3-x86_64.AppImage
Summary: Render fails instantly 21.12.3 on Linux Mint kdenlive-21.12.3-x86_64.AppImage
Status: RESOLVED FIXED
Alias: None
Product: kdenlive
Classification: Unclassified
Component: Video Display & Export (show other bugs)
Version: 21.12.3
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Jean-Baptiste Mardelle
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-23 09:47 UTC by david rayner
Modified: 2022-05-10 14:31 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.04.1
fritzibaby: timeline_corruption+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description david rayner 2022-03-23 09:47:06 UTC
SUMMARY
Rendering of /home/david/Videos/kia/kiapicantoyt3.mp4 crashed 

STEPS TO REPRODUCE
1. Produce extremely simple video 
2. Click render to file
3. Rendering of /home/david/Videos/kia/kiapicantoyt3.mp4 crashed

ALWAYS WORKS using same project file IF I REVERT to 21.12.2 or earlier . (regardless of whether created by
21.12.2 or 21.12.3)

OBSERVED RESULT

WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
kf.notifications: Audio notification requested, but sound file from notifyrc file was not found, aborting audio notification
* CREATED JOB WITH ARGS:  ("/usr/bin/melt", "/tmp/kdenlive-PTKEwj.mlt", "/home/david/Videos/untitled.mp4", "-pid:89941", "-out", "124")
starting kdenlive_render process using:  "/tmp/.mount_kdenliJhqFQ8/usr/bin/kdenlive_render"

(kdenlive_render:90023): GdkPixbuf-WARNING **: 09:38:49.540: Cannot open pixbuf loader module file '/usr/lib64/gdk-pixbuf-2.0/2.10.0/loaders.cache': No such file or directory

This likely means that your installation is broken.
Try running the command
  gdk-pixbuf-query-loaders > /usr/lib64/gdk-pixbuf-2.0/2.10.0/loaders.cache
to make things work again for the time being.

EXPECTED RESULT


SOFTWARE/OS VERSIONS
Linux Mint 20.3 kdenlive-21.12.3-x86_64.AppImage  

ADDITIONAL INFORMATION
Same failure if I use a nightly download of Kdenlive
Comment 1 david rayner 2022-03-23 16:07:36 UTC
Melt Is Already The Newest Version (6.26.1-1~Ubuntu20.04.1)
Comment 2 david rayner 2022-03-24 13:38:24 UTC
Rendering of /home/david/Documents/fred.mp4 crashed

/tmp/.mount_kdenli8lEgZl/usr/bin/melt: symbol lookup error: /tmp/.mount_kdenli8lEgZl/usr/lib/ladspa/alias_1407.so: undefined symbol: libintl_bindtextdomain
Comment 3 Vitaly "_Vi" Shukela 2022-05-05 20:36:47 UTC
Still reproducible for kdenlive-22.04.0-1-x86_x64.AppImage:

Rendering of /home/vi/Videos/untitled.mp4 crashed

/tmp/.mount_kdenlihBl3HV/usr/bin/melt: symbol lookup error: /tmp/.mount_kdenlihBl3HV/usr/lib/ladspa/alias_1407.so: undefined symbol: libintl_bindtextdomain
Comment 4 Vitaly "_Vi" Shukela 2022-05-05 22:32:46 UTC
Workaroud: save render script (mlt) from GUI, install "melt" package in distro, then render the video from CLI using /usr/bin/melt outside AppImage.
Comment 5 Sam K 2022-05-06 08:25:55 UTC
Hi. I'm having the same problem. When I try to render a very simple timeline with just one clip and no effects whatsoever, I get the following error messages:

Kdialog: Rendering of /home/sak/Videos/untitled.mp4 aborted, resulting video will probably be corrupted.

Error Log: Rendering of /home/sak/Videos/untitled.mp4 crashed

/tmp/.mount_kdenligxPvey/usr/bin/melt: symbol lookup error: /tmp/.mount_kdenligxPvey/usr/lib/ladspa/alias_1407.so: undefined symbol: libintl_bindtextdomain

"Help / Reset Configuration..." doesn't help.

Also, when I start Kdenlive, it first says: "Unable to create io-slave. Can not find io-slave for protocol 'tags'."

Thanks
Sam

kdenlive-22.04.0-1-x86_x64.AppImage (on Triskel GNU/Linux libre 10)
Comment 6 david rayner 2022-05-06 09:00:04 UTC
thanks workaround works for me even with an older version of melt

env melt --version
melt 6.26.1
Comment 7 emohr 2022-05-07 08:09:13 UTC
We fixed some build problems with MLT. Please try again with the nightly build: https://binary-factory.kde.org/job/Kdenlive_Nightly_appimage-centos7/
Comment 8 Vitaly "_Vi" Shukela 2022-05-07 08:52:52 UTC
@emohr

Tried kdenlive-master-208-linux-64-gcc.AppImage: rendering now works out of the box: `/tmp/.mount_kdenliNUbyI1/usr/bin/melt` is working.
Comment 9 Sam K 2022-05-10 12:25:54 UTC
Okay, I just tried "kdenlive-master-211-linux-64-gcc.AppImage", RENDERING IS WORKING NOW.

I still get the error message "Unable to create io-slave. Can not find io-slave for protocol 'tags'." when I start Kdenlive, though, but that's a different story (probably some KDE Plasma thing).

Thank you!
Comment 10 emohr 2022-05-10 14:31:52 UTC
Thank you for the feedback and contribution. Glad to hear it works. 

The fix will be in the upcoming 22.04.1 version.

I close this bug. If it still appears in the latest version, please feel free to re-open it and update the affected version number.