Bug 451809 - Missing "Open in new window" option when right clicking folders in the path
Summary: Missing "Open in new window" option when right clicking folders in the path
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kio
Classification: Unclassified
Component: URL navigator (show other bugs)
Version: 5.92.0
Platform: Archlinux Packages Linux
: NOR wishlist
Target Milestone: ---
Assignee: KIO Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-23 02:32 UTC by Prajna Sariputra
Modified: 2022-04-19 01:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.94


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Prajna Sariputra 2022-03-23 02:32:26 UTC
SUMMARY
In Dolphin right clicking on folders in the main view or on any entry in the places panel gives both "Open in new tab" and "Open in new window" options, however right clicking on the path bar only gives the "Open in new tab" option. While it is possible to detach the tab and create a new window afterwards, it seems odd to me that the option to open a new window is missing in this case, while it is present everywhere else in the app.

Granted, it is possible to detach tabs to create a new window afterwards, and while writing this I just realised that split view can solve the use case I wanted this feature for (say the current path is a/b/c, and I then need to find/open something in a/d/e, but I'd like to still be able to look at a/b/c at the same time, my first thought was to right click a in the path and try to open it in a new window). Still, a new window is more flexible than the split view since then it doesn't need to be side by side with the original view (say the new window could go on another display), so I don't think it would be completely redundant.

Also, I put this under frameworks-kio since that's where bug 402073 (the one referring to adding the "Open in new tab" option to the path context menu) is, I hope this is the right place.


STEPS TO REPRODUCE
1. Open Dolphin
2. Right click an entry in the path/location bar

OBSERVED RESULT
"Open in new tab" is present in the context menu, but not "Open in new window".

EXPECTED RESULT
Both "Open in new tab" and "Open in new window" should be present, just like when right clicking a folder.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
Dolphin Version: 21.12.3
KDE Plasma Version: 5.24.3
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 5.16.16-arch1-1 (64-bit)
Graphics Platform: Wayland
Comment 1 Ahmad Samir 2022-04-18 18:25:33 UTC
Git commit a0016644b692a1ca6ebf8e1585b01d52ca777995 by Ahmad Samir.
Committed on 17/04/2022 at 14:51.
Pushed by ngraham into branch 'master'.

KUrlNavigator: offer open in new window action too

To be consistent with other places where both open in tab and open in
window are offered, e.g. KFilePlacesView, Dolphin icon view context
menu ...etc.
FIXED-IN: 5.94

M  +19   -5    src/filewidgets/kurlnavigator.cpp

https://invent.kde.org/frameworks/kio/commit/a0016644b692a1ca6ebf8e1585b01d52ca777995
Comment 2 Prajna Sariputra 2022-04-19 01:14:12 UTC
I applied the patch on top of KIO 5.93.0, and it works with Dolphin 21.12.3 after I applied this MR to it: https://invent.kde.org/system/dolphin/-/merge_requests/286

Thanks!