Bug 451795 - [Wayland] KRunner not opening in the monitor the cursor is in
Summary: [Wayland] KRunner not opening in the monitor the cursor is in
Status: RESOLVED DUPLICATE of bug 427069
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: 5.24.3
Platform: Fedora RPMs Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Alexander Lohnau
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2022-03-22 15:24 UTC by Alexandre Cavalheiro
Modified: 2022-03-27 11:32 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Cavalheiro 2022-03-22 15:24:41 UTC
SUMMARY
Whenever I invoke KRunner using the default key-bind (Alt + Space) it opens in my secondary monitor, even if the cursor isn't located in it, while in X11 it opens in whatever monitor my cursor is located. I must note that even if I make it my primary monitor the behaviour is the same, my "primary" monitor is using a DisplayPort while my secondary is using an HDMI port; for the sake of simplicity I'll call the one using the HDMI port as my "secondary" monitor.


STEPS TO REPRODUCE
1. Open KRunner

OBSERVED RESULT
KRunner opens, but in the secondary monitor.

EXPECTED RESULT
For KRunner to open in the monitor where the cursor is located.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 5.16.15
KDE Plasma Version: 5.24.3
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Comment 1 Kishore Gopalakrishnan 2022-03-27 11:32:44 UTC

*** This bug has been marked as a duplicate of bug 427069 ***