Bug 451229 - "Open message" button in notification doesn't open Kmail. It opens Whatsie instead.
Summary: "Open message" button in notification doesn't open Kmail. It opens Whatsie in...
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.19.2
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-07 10:53 UTC by Samuele
Modified: 2022-04-24 17:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.20.0


Attachments
Screencast of what happens clicking on the button. (663.29 KB, video/mp4)
2022-03-07 10:53 UTC, Samuele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuele 2022-03-07 10:53:48 UTC
Created attachment 147341 [details]
Screencast of what happens clicking on the button.

SUMMARY
Unfortunately in this case I don't know how to attach a backtrace , because the issue doesn't happen in the form of a crash. If you know of a way to share with you additional data, please tell me.

I use Kmail in italian, so in describing what I see on the screen I'll try to translate it, but I could make mistakes. I'm sorry.

When I receive a new email, a notification appears from the system tray and between the buttons (as to sign the message as "read", or to delete it), I have the button to open the message. I don't know why, but such button doesn't open the message anymore. Instead, it focuses a different program I have on my computer, that is "Whatsie". When Whatsie isn't opened, the button simply doesn't do anything.

STEPS TO REPRODUCE
1. Receive a new email
2. Receive the notification of the new email
3. Click on the button to open the message. If you don't see such button, go Kmail > Settings > Configure Kmail > Extensions > The gear icon after "New messages notifications" > Show buttons.

OBSERVED RESULT
When Whatsie is opened, it gets focused. When Whatsie isn't opened, nothing happens.

EXPECTED RESULT
Kmail should open showing me the new message.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: KDE Neon 5.24
KDE Plasma Version: 5.24.2
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.3
Comment 1 Samuele 2022-04-24 16:54:09 UTC
I'm sorry if I cited "Whatsie". It doesn't matter: buttons doesn't work with it installed or not.
Comment 2 Laurent Montel 2022-04-24 17:18:19 UTC
it's fixed in 5.20.0

Regards